(Pfsense 2.1 | Pfsense 2.2.4) Portal Cautivo + squid3-dev no redirecciona en 2.1



  • Saludo a todos los que pasen por el post.

    Quiero armar un squid3 con autenticación ->Portal cautivo

    Tengo el siguiente escenario (laboratorio)

    pfsense 2.2.4 + squid3: CP Funciona correctamente. Portal Cautivo en if LAN con autenticación Local, me redirecciona a la landing page que armé. Una vez autenticado, la navegación figura (con ip de origen) en el access.log.
    Fracasa la investigación cuando habilito la autenticación por portal cautivo. Crashea el squid3 una vez que el usuario se autentica. Leí por ahí que marcelloc comentó que hay que esperar a la versión 2.3 de pfsense

    Por lo que decidí realizar la prueba en una versión antigua de pfSense, para ver que sea posible

    pfSense 2.1 + squid3-dev: El pfsense no está redireccionando las peticiones iniciales a la Landing Page. Seguí esto al pie de la letra https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting#Captive_portal_not_redirecting.
    Intenté emular la configuración del pfsense 2.2.4 en el 2.1, y no funciona.

    pfsense 2.2.4: 10.0.0.229
    pfsense 2.1: 10.0.0.15
    host windows-lab: 10.0.0.20

    En el host windows:
    gateway: 10.0.0.229
    DNS primario: 10.0.0.229

    portal cautivo funciona

    En el host windows
    gateway: 10.0.0.15
    DNS primario: 10.0.0.15

    Corrí ccleaner, rebooteé el equipo

    portal cautivo no funciona.

    Hay algún workaround para la versión 2.1 de pfsense que me estoy perdiendo? Las logs no dicen nada. al menos no las que miré (firewall + captive portal auth)

    Si quieren darme una mano, aunque sea, diciéndome qué log mirar, se los agradecería

    Vale la pena aclarar que en ambas versiones pude lograr que ambos servicios corran en simultáneo (Salvo como dije, cuando activo la autenticación por portal cautivo)

    Disculpen lo extenso del mensaje,

    Saludos!



  • Probaste sin squid ?



  • Hola, gracias por responder

    Acabo de desinstalar squid y sigue sin redireccionarme. Tengo que buscar la solución por otro lado

    Saludos!


Log in to reply