[Pendiente]pfsense 2.1.5 + portal cautivo: No redirecciona



  • Hola estimados.

    Tengo instalado pfsense 2.1.5 + portal cautivo en if LAN (em1=10.0.0.8/24) + squid3 con autenticación por portal cautivo

    Cuando quiero navegar desde el host windows, no me redirecciona a la página de login. No obstante si ingreso la url de login manualmente en el navegador, puedo autenticar sin ningún inconveniente y posteriormente navegar, autenticando en squid3 automáticamente.

    El comando ipfw -x em1 show devuelve la siguiente información:

    65291    0      0 allow pfsync from any to any
    65292    0      0 allow carp from any to any
    65301 2146  97132 allow ip from any to any layer2 mac-type 0x0806,0x8035
    65302    0      0 allow ip from any to any layer2 mac-type 0x888e,0x88c7
    65303    0      0 allow ip from any to any layer2 mac-type 0x8863,0x8864
    65307    1     46 deny ip from any to any layer2 not mac-type 0x0800,0x86dd
    65310    0      0 skipto 65314 ip from any to { 255.255.255.255 or 10.0.0.8 } dst-port 3128 in
    65310    0      0 skipto 65314 ip from { 255.255.255.255 or 10.0.0.8 } 3128 to any out
    65310  757  69670 allow ip from any to { 255.255.255.255 or 10.0.0.8 } in
    65311    0      0 allow ip from { 255.255.255.255 or 10.0.0.8 } to any out
    65312    0      0 allow icmp from { 255.255.255.255 or 10.0.0.8 } to any out icmptypes 0
    65313    0      0 allow icmp from any to { 255.255.255.255 or 10.0.0.8 } in icmptypes 8
    65314    0      0 pipe tablearg ip from table(3) to any in
    65315    0      0 pipe tablearg ip from any to table(4) in
    65316    0      0 pipe tablearg ip from table(3) to any out
    65317    0      0 pipe tablearg ip from any to table(4) out
    65318    0      0 pipe tablearg ip from table(1) to any in
    65319    0      0 pipe tablearg ip from any to table(2) out
    [b]65532  114   5776 fwd 127.0.0.1,8000 tcp from any to any dst-port 80 in[/b]
    65533    0      0 allow tcp from any to any out
    65534 5295 446924 deny ip from any to any
    65535   12   7019 allow ip from any to any
    
    

    veo que el fwd lo hace a 127.0.0.1:8000 y me pregunto si no debería redireccionarme a 10.0.0.8:8002. Si esto era un bug, quisiera saber cómo puedo depurarlo.
    Si no es un bug, algún troubleshooting para  hacerlo funcionar?

    config host Windows 7:
    ip: 10.0.0.61/24
    gw: 10.0.0.8
    dns server:10.0.0.8

    ![Captura de pantalla de 2015-11-03 17-48-51.png](/public/imported_attachments/1/Captura de pantalla de 2015-11-03 17-48-51.png)
    ![Captura de pantalla de 2015-11-03 17-48-51.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2015-11-03 17-48-51.png_thumb)
    ![Captura de pantalla de 2015-11-03 17-49-12.png](/public/imported_attachments/1/Captura de pantalla de 2015-11-03 17-49-12.png)
    ![Captura de pantalla de 2015-11-03 17-49-12.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2015-11-03 17-49-12.png_thumb)
    ![Captura de pantalla de 2015-11-03 17-49-36.png](/public/imported_attachments/1/Captura de pantalla de 2015-11-03 17-49-36.png)
    ![Captura de pantalla de 2015-11-03 17-49-36.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2015-11-03 17-49-36.png_thumb)
    ![Captura de pantalla de 2015-11-03 17-54-54.png](/public/imported_attachments/1/Captura de pantalla de 2015-11-03 17-54-54.png)
    ![Captura de pantalla de 2015-11-03 17-54-54.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2015-11-03 17-54-54.png_thumb)



  • Que tienes configurado en las settings de captive portal ?

    Me da que el problema esta en la direccion que le pusiste.



  • Gracias Trasher.

    No agregué ninguna configuración al captive portal. adjunto imágenes.

    (Así mismo lo tengo configurado en un pfSense 2.2.4 y el redireccionamiento funciona, pero no aplica la autenticación de Squid con portal cautivo, por lo que decidí volver a esta versión)

    ![Captura de pantalla de 2015-11-04 09-33-05.png](/public/imported_attachments/1/Captura de pantalla de 2015-11-04 09-33-05.png)
    ![Captura de pantalla de 2015-11-04 09-33-05.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2015-11-04 09-33-05.png_thumb)
    ![Captura de pantalla de 2015-11-04 09-33-18.png](/public/imported_attachments/1/Captura de pantalla de 2015-11-04 09-33-18.png)
    ![Captura de pantalla de 2015-11-04 09-33-18.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2015-11-04 09-33-18.png_thumb)
    ![Captura de pantalla de 2015-11-04 09-33-36.png](/public/imported_attachments/1/Captura de pantalla de 2015-11-04 09-33-36.png)
    ![Captura de pantalla de 2015-11-04 09-33-36.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2015-11-04 09-33-36.png_thumb)



  • Como quieres que direccione el portal cautivo a una pagina que no le tienes indicada ? No creo que pueda adivinar.

    Esta mal configurado el portal cautivo ( de hecho no tienes nada configurado ), en la documentacion hay un ejemplo que posteo bellera, es de una version vieja, pero todavia funciona en estos dias.



  • Pero si lo tengo exactamente igual en un pfSense 2.2.4 y funciona, no entiendo qué tengo mal configurado…

    Decís que en Pre-authentication redirect URL ponga 10.0.0.8:8002?

    Ayuda!  :P

    Muchas gracias por responder



  • Tienes el cp configurado para escuchar peticiones de tu red en la tarjeta LAN para los clientes que quieran accesar a Internet via puerto 80/443.
      Tienes algun otro servicio similar como squid escuchando peticiones en la misma tarjeta?



  • Probé sin squid y el problema era el mismo.

    Instalé Squid para probar la autenticación por portal cautivo (funciona)

    Acabo de desinstalar squid para ver si funciona el redireccionamiento.

    Después comento algún avance

    Gracias periko por tu respuesta



  • Muy bien, tenemos 2 maneras y pueden chocar 1 de ellas.

    a) Captive Portal+squid, cuando activamos squid para dar soporte a cp todo a la misma tarjeta.
      Lo que pasa aqui es que squid se pone en modo transparente y cuando un cliente se conecta le responde cp para autentificacion y por detras sin que el usuario se de cuenta squid cache lo que puede, no se tiene que hacer nada de lado del cliente, todo es transparente.

    b) CP+squid todo a la misma tarjeta.
    Cuando se instalana ambos servicios y no se le dice a squid que de soporte a cp ahi problemas, por que ambos estas para contestar peticiones cuando los clientes tratan de navegar y mas squid en modo transparente. Por ello no puede trabajar ambos en la misma interfaz, a veces por error hacen esto y se meten en problemas, si squid no esta en modo transparente puedes trabajar ambos pero tendrias que indicarle a el cliente quien si puede y quien no puede si no es por medio de squid, se pone complicado pero ahi vikingos a veces.

    Otras veces me ha tocado de mucho estar probando los navegadores en su cache tienen informacion obsoleta y nos causan problemas, por ello prefiero limpiar sus caches con ccleaner y empezar de nuevo.

    Es solo informativo este correo, saludos.



  • Ok, le mandé un mp a MarcelloC. Es un tipo muy correcto, supo responder con exactitud mi cuestión. Sinceramente voy a esperar a la versión 2.3 para realizar el experimento.

    @marcelloc:

    @rocaembole:

    Many thanks for your effort. I'm from Argentina. I want to say thank you. I don't know if you are going to read this, and i don't know if you'll understand my english neither.

    I have a question:

    It is possible to configure Captive Portal + Squid3 w/ Auth with CP credentials on pfsense 2.2.4?

    If it is not: Why?

    And there's any version that can do this work? which one?

    TYVM for the time you expend reading my MP

    Bye, God bless you and your work.

    Hi. The problem with cp + squid3 on 2.2 are the pbi package encoding. on pfsense 2.3 pbi are not used any more, so will work without hacks on 2.3

    For now you can replace squid pbi binaries with a squid3 freebsd compiled  package.

    I have some video lesson that may help if you're not familiar with freebsd ports and compiling.
    http://sys-squad.com/sys/curso/48

    Gracias por sus comentarios


Log in to reply