OpenVPN Client-to-Site sehr langsam



  • Hallo zusammen,

    das Thema beschäftigt mich nun schon mehrere Tage.
    Zur Ausgangslage:

    • Virtualisierte pfSense –> Version 2.2.4 (AMD 64) auf ESX 5.5
    • Hardware: 4GB Ram, Dual-Core, ausreichend performant.
    • Platziert im Rechenzentrum, daher ziemlich starke WAN-Anbindung (Download >100mbit, Upload >70mbit)
    • OpenVPN Client-to-Site Verbindungen vorhanden die über LDAP Auth. (Active Directory Anbindung)
    • Verschlüsselung: AES 256bit CBC

    Bei meinen Messungen ist mir aufgefallen, dass bei circa 3mbit das Limit erreicht ist.
    Bisher habe ich diverse Tests durchgeführt:

    • Verschlüsselung herabgesetzt, was sich jedoch wenn überhaupt nur auf die CPU-Last ausgewirkt hat.
    • Verschiedene OpenVPN Clients
    • Folgende Parameter wurden ebenfalls testweise in der Advanced Config gesetzt ( tun-mtu 1500; mssfix 1400;)
    • LZO Verschlüsselung Optionen in allen Varianten ausprobiert -> adaptiv steht nun und hat bis dato auch immer gut funktioniert

    Meine Recherchen haben ergeben, dass viele ein Downgrade auf 2.15 durchführen und es anschließend mit höherer Bandbreite läuft aber das wollte ich nur ungern.

    Hat jemand Erfahrungswerte oder ein ähnliches Problem und dessen Lösung?

    Viele Grüße



  • Update:

    Ich habe heute weitere Tests mit ältern Versionen durchgeführt:

    • 2.2.3 -> Keine Verbesserung der Bandbreite
    • 2.2.2 -> Keine Verbesserung der Bandbreite
    • 2.2.1 -> Keine Verbesserung der Bandbreite
    • 2.2 -> Keine Verbesserung der Bandbreite
    • 2.1.5 -> Keine Verbesserung der Bandbreite

    Dann habe ich geupdatet auf die 2.2.5 Version, die seit heute released ist.
    Auch hier ist keine Verbesserung zu verbuchen…


Log in to reply