Exclude network destinations (thinking: Hulu) from encryption?



  • Howdy,

    I've followed the guide to get PIA working (https://forum.pfsense.org/index.php?topic=76015.0) and it's worked very well, with one exception: Hulu doesn't work. I'm aware that the solution is to simply route traffic destined for Hulu normally as opposed to sending it through the PIA interface, but I can't seem to get this bit working. I've created an alias containing all the IPs I could find for Hulu (a lot of dig work), so now I just need to figure out how to correctly exclude traffic destined for this alias from being sent to the PIA OpenVPN interface.

    I've tried configuring the following, to no success:

    • Adding an outbound firewall rule for LAN to state "any" protocol from "any" source destined to the "Hulu" alias uses the WAN gateway
    • Adding an outbound firewall NAT rule to state WAN interface from "any" source destined to the "Hulu" alias set the NAT address to WAN address

    I've tried one or the other, then both in conjunction, and have had no luck. Based on which I've done (firewall rule, NAT rule, or both) either I get a message from Hulu whining about the VPN, or the media player simply fails to load and display some generic error. I've monitored the outbound traffic destined for Hulu so I know that my alias has the correct IPs defined, but it doesn't appear to work. My guess is that maybe the Hulu media player (when it errors out instead of yelling at my about my VPN) is trying to load resources from some other IP/CDN, but that's speculation on my part. What am I doing wrong?



  • try the Don't pull routes option in the openvpn-config. it'll prevent openvpn from overwriting the routing-table.

    you will have to specify what traffic you want / don't want to go through PIA



  • leighno5 - Did you get this working? I am having the same issue. If you did, can you post what you did to make it work? I came up with a boatload of IP addresses for Hulu, but with them using Akamai, it's hard to pinpoint the correct ones.

    I did notice if I check the No Pull box, start Hulu, then uncheck and apply, Hulu continues to work.


Log in to reply