Problemas con OPENVPN



  • Hola:
    He configurado mi red para acceder desde mi móvil android u otro dispositivo win desde fuera a mi red de trabajo.
    Conecto correctamente y navego perfectamente desde el móvil pero no consigo de ninguna manera poder acceder al NAS que tengo en la red  del pfsense.

    Os paso captura de las reglas del firewall por si alguien me puede ayudar.
    Gracias de antemano por vuestra ayuda.







  • Que extremo eres, no necesitas replicar las regla en tu 1er imagen, es la misma regla 2 veces eso no garantiza nada, solo ocupas 1.

    Ahora cuando dices que conectas y navegas sin problemas, te refieres a que puedes entrar a tu VPN desde Internet y accesar a tu red interna por la VPN?

    Es el unico servicio que no responde desde fuera?

    Si es el caso, esta dentro de tu misma red y usando el mismo gateway que tu red que si puedes accesar.

    Tienes 2 reglas iguales en seccion de OpenVPN elimina 1.

    Ahora en tu WAN aparecen 2 conexiones hacia openVPN, entonces tienes 2 servicios de OpenVPN?

    Siento que mas informacion falto aqui, saludos.



  • Hola:
    Muchas gracias por tu ayuda. No es que sea extremo , es ignorancia. :)

    En la primera imagen tengo dos reglas porque como no me funcionaba configuré  vpn en el puerto 1194 y después lo hice en la 1195.
    Cada regla es a un puerto.

    Desde el movil conecto bien con la vpn . Me asigna una ip del tunel y puedo navegar por internet perfectamente. Pero cuando intento acceder a los dispositivos que tengo en la red ( en este caso un NAS ) nunca encuentra el servidor. NO hay forma de acceder a los recursos de la LAN

    El NAS está en la misma red que el pfsense.

    Si, en la WAN hay dos conexiones a la vpn por el tema que he comentado antes de que he creado dos servicios.

    Si necesitas capturas concretas puedo hacertelas son problemas. Gracias otra vez.



  • Hola.

    Bien, una cosa es que cruces atraves del tunnel y navegues.

    Y otra que tengas acceso a los recursos.

    Mira existe mucha documentacion, te recomiendo darle una revisada, vas aprender mucho y hasta del problema saldras.

    Ya si de plano no das, pues regresas, saludos.



  • Hola:
    Gracias por tu ayuda. Llevo dos días buscando y leyendo  no encuentro la solución. Pero seguiré buscando.

    Mi red es la 172.16.10.0/16 y el tunel la 10.10.10.0/24. Cuando estoy conectado no
    puedo hacer ping a la 172.16.10.0 pero no sé por qué.

    Gracias de nuevo.



  • Hola otra vez.
    Al final lo he hecho ir. El problema era el enrutamiento. La vpn no conocía mi red LAN, la 172.16.10.0
    Marcando la casilla de forzar a los clientes generar el trafico por el gateway accedo a los recursos de la lan y navego.

    Pero sigo sin entender por qué. Gracias de nuevo.






  • Todo eso viene en la doc, es un parametro basico, que bueno que ya lo resolvistes, saludos.


Log in to reply