Diagnostics edit file -> 12,678 byte maximum ?



  • I know this was mentioned in a previous thread - but I think the 'use ssh' line is a cop out.

    I have a simple block list setup for pfblocker that I keep up to date via Diagnostics > Edit file - the total file is ~ 30K in size.
    After the last update I was no longer able to save the file so I split it into 5 parts ( 0.0.0.0-49.255.255.255,50.0.0.0-99.255.255.255,… ) - it was a pain but it worked.
    Now I have the same problem with one of these part files.

    It seems that the max file size that can now be saved is exactly 12,678 byte - one byte more and the file won't save - it just gets stuck at "Saving file..." and the file never saves.
    This is happening in the latest versions of IE,FF ,CH & OP.

    Why was this limit introduced  & can we get the larger file handling re-enabled ?


  • Banned

    There is no such limit in the first place. I just edited a 1MB file.



  • ya - I was just playing with it some more
    it doesn't seem to be the file size as it first appeared.

    I had a file where adding one character prevented a save and removing that character re-enabled the save
    But when I tried to to split the file - I couldn't save one half of it.
    I thought maybe a control character hiding in there or something - but by cutting the file up into smaller bits there is no one part that can't be saved but trying to save the entire file fails.

    Will keep digging.



  • Yeah, that was my thread (https://forum.pfsense.org/index.php?topic=102069.0). I'm interested to see what comes of this too. Although ssh and logging in to the pfSense box itself are workarounds, using the GUI would still be easier and there is no reason why that shouldn't work as epected.

    I too had thought it was the size of the file, but there may well be something else going on, or more than one issue. Either way, the "Edit File" and "Filer" functions don't seem to function as well as they might.


Log in to reply