[gelöst]Ins Knie geballert - Tipp erbeten



  • Guten Tag allerseits!

    Ich bin pfSense Neugling, schaffte es aber anhand der vielen Infos und Anleitungen hier eine funktionierende Firewall aufzubauen. Ich bestellte ein APU1D4 Board, konnte alles richtig zusammenbauen und die Software installieren. Bei der Konfiguration im WebGui installierte und konfigurierte ich Squid und SquidGuard.

    Nach ein paar Tagen reibungslosem Betrieb unterlief mir ein dummer Fehler. Ich aktivierte versehentlich statt im WAN Interface auch noch im LAN Interface die beiden Optionen Disable Private Net Works / Bogon Networks.

    Tja, nun komme ich nicht mehr auf das WebGui, weder über die WAN noch über die LAN Schnittstelle. Beim eintippen der URL (LAN IP = 192.168.1.1) von einem PC direkt im grünen Netz (PC IP = 192.168.1.7) dreht sich nur der Zeiger im Browser bis irgendwann die Timeout Meldung kommt.

    Ich habe versucht über die Suche eine Lösung zu finden dh was ich tun kann. Ich weiss nicht mehr, ob ich an der Anti Lock Rule etwas geändert habe oder nicht. Bevor ich nun noch weiter Schaden anrichte, wollte ich gerne fragen ob ihr mir vielleicht einen Tipp geben könntet wo ich anfangen soll.
    Herzlichen Dank!

    Nachtrag 23.11.2015:
    Vielen, vielen herzlichen Dank! Es funktioniert wieder alles prächtig, die Anleitung war perfekt  ;D ;D ;D



  • Hallo,

    kommst Du denn per ssh auf die Maschine?
    Dann kannst Du in der shell ein pfctl -d eingeben. Der Befehl deaktiviert die Firewall. Mit einem pfctl -e wird sie wieder aktiviert.
    Ansonsten kannst Du direkt am Host im Menü die 8 drücken und kommst zur shell.

    Viele Grüße
    Tino


  • LAYER 8 Moderator

    Hallo Rene,

    eigentlich sollte die Anti Lock Rule genau soetwas verhindern. Entweder wurde diese ausgeschaltet oder sie greift (leider) für dich in der falschen Reihenfolge. Nichts desto trotz dürfte der Filter dich jetzt erstmal dran hindern, auf die WebGUI zu kommen.

    Du kannst dir aber behelfen, wenn du Consolen Zugriff auf die APU herstellst (entweder via serieller Konsole oder SSH).

    1. via serielle Konsole verbinden / SSH verbinden
    2. Punkt 8 auswählen - Shell
    3. jetzt deinen Browser in Stellung bringen, du solltest nun nämlich recht schnell sein
    4. tippe auf der Shell "pfctl -d" ein - nun hast du den kompletten Paketfilter deaktiviert(!)
    5. nun gehst du fix auf die WebGUI und nimmst die Haken beim LAN Interface wieder raus und drückst speichern
    6. anschließend in der Konsole "pfctl -e" eingeben, sollte aber nach dem Speichern des LAN Interfaces eh wieder aktiviert worden sein.

    Warum schnell sein? Wenn der komplette PF deaktiviert wurde, gelten keine Firewallregeln mehr, aber auch kein NAT bspw. Damit ist dann meist auch keine Kommunikation mit Internet und Co mehr möglich, dafür ist jeder Traffic intern/geroutet erlaubt. Deshalb sollte man so etwas schnell wieder rückgängig machen und schnellstens den Filter wieder anmachen.

    Viele Grüße

    Edit: Oh der Tab war wohl zu lange offen, Tino hat da ebenfalls die korrekte Variante schon gepostet :)



  • Vielen herzlichen Dank für eure Tipps! Morgen bekomme ich das ausgeliehene USB-Serial Kabel zurück, dann kann ich mich an die Arbeit machen  :)


Log in to reply