Squid+squidgaurd not working in bridge mode in pfsense



  • I have installed pfsense on bridge mode and without squid it's working but if i enable to squid and squidgaurd then internet is not working. i have setup as below.

    internet–-----------netgear-------WAN pfsense LAN------PC

    netgear=192.168.1.1 (gw)

    pfsense wan:192.168.1.13
    pfsense lan:192.168.1.166

    squid listen :LAN and transparent listen : LAN with ssl enable

    pc ip:192.168.1.90 gateway:192.168.1.1

    my main goal is my machine gateway and netgear router gateway must same(like 192.168.1.1).
    is there any other way plz suggest me.



  • Sorry but I don't think that network design makes much sense. If you're trying to use transparent proxy, then you can't have the netgear as your default gateway, it must be pfsense. Best you give up on the transparent proxy and use WPAD or statically define the proxy server settings.

    go back to the drawing board with your design, it just won't work.


Log in to reply