[SOLVED] igmpproxy won't start at boot



  • 2.3-ALPHA (amd64)
    built on Tue Nov 17 12:19:13 CST 2015
    FreeBSD 10.2-STABLE

    igmpproxy won't start at boot and displays on the logs :

    php-fpm[40128]: /status_services.php: The command '/usr/local/sbin/igmpproxy -d4 -c /tmp/igmpproxy.conf' returned exit code '1', the output was 'igmpproxy: illegal option – 4'

    It won't start because the command line options for igmpproxy 0.1 are different from the existing version on pfSense 2.3.

    Issue solved by modifying mwexec("/usr/local/sbin/igmpproxy -d4 -c {$g['tmp_path']}/igmpproxy.conf") to
    mwexec_bg("/usr/local/sbin/igmpproxy -v {$g['tmp_path']}/igmpproxy.conf") in /etc/inc/services.inc.

    Regards,


  • Banned

    Wow, it's finally updated?



  • Fixed, thanks.



  • 2.3-ALPHA (amd64)
    built on Thu Nov 19 20:14:06 CST 2015
    FreeBSD 10.2-STABLE

    Thanks Chris,

    The issue still there because of the option -c is not valid anymore as stated in the logs :
    php-fpm[86988]: /status_services.php: The command '/usr/local/sbin/igmpproxy -c /tmp/igmpproxy.conf' returned exit code '1', the output was 'igmpproxy: illegal option – c'

    To not interrupt the booting process the igmpproxy should run in background by using "mwexec_bg" and "-v" option :
    mwexec_bg("/usr/local/sbin/igmpproxy -v {$g['tmp_path']}/igmpproxy.conf") in /etc/inc/services.inc.

    Kind Regards,



  • I thought that was odd as I didn't see the -c option there, but had mis-read what you pasted. Fixed again.

    Should be safe to background so switched to _bg as well.

    Thanks!



  • 2.3-ALPHA (amd64)
    built on Fri Nov 20 05:28:06 CST 2015
    FreeBSD 10.2-STABLE

    Tested and woks… Thanks

    @doktornotor:

    Wow, it's finally updated?

    Like it  ;)

    P.S: Thanks to the posters on https://forum.pfsense.org/index.php?topic=93293.msg547128#msg547128


Log in to reply