Modulos de PHP



  • Buenos Dias, estoy utilizando la version 2.2.5 , quisiera saber como activar modulos de php, he logrado levantar el modulo de mysql, pero no se como levantar el modulo zip de php, he instalado a mano paqueteria pero al parecer hago pure el sistema,   he actualizado la base de repositorio

    pkg udpdate

    al buscar paqueteria

    pkg search php | grep zip
    php5-zip

    y la encuentro pero al instalar tambien me jala php5, lo raro es que al verificar paquetes instalados (antes de instalar esto)

    pkg info

    solo me sale el manejador de paquetes ( pkg) como instalado, no aparece php ni nada, tendran una idea de que debo de hacer??? Gracias y  SALUDOS



  • pkg update

    Hace tiempo que no he instalado paquetes "a mano" en pfSense pero diría que eso no lo debes hacer.

    El motivo es que pfSense es un FreeBSD tuneado y le faltan muchas herramientas, a fin de reducirlo al máximo.

    Por tanto, entiendo que la estructura típica de gestión de dependencias no está y debes instalar los binarios uno a uno con pkg_add

    Y esperar a que se queje cuando le falte un paquete para hacer su pkg_add

    Si con pkg_add no te funciona entonces el único remedio es hacerlo todo manualmente. Ejemplo:

    https://forum.pfsense.org/index.php?topic=74317.msg406295#msg406295



  • ¡Ojo con el ejemplo!

    pfSense 2.25 es FreeBSD 10.1

    https://doc.pfsense.org/index.php/Versions_of_pfSense_and_FreeBSD



  • Gracias voy a revisar la documentacion y te comento como me fue. Gracias y SALUDOS



  • Mucho tiempo atras trate de montar mysqli ya que es mejor driver que el que viene de fabrica mysql, pero no logre hacerlo, por haya los gringos se enojaron por que queria hacerlo.

    Claro, lo compile en una caja freebsd 8.x.

    Suerte!!!


Log in to reply