Problems after upgrade 2.2.4 to 2.2.5



  • hi.

    i get this error from captive portal after upgrade to 2.2.5 version

    logportalauth[18435]: Zone: xxxxx - Still unable to create tables for xxxx. Error message: disk I/O error. Remove the database file manually and try again.
    Nov 23 14:54:46 logportalauth[18435]: Zone: xxxx - Error during table xxxx creation. Error message: database is locked. Resetting and trying again.

    the captiver portal restart and i lost all the users.

    some help please.

    thanks in advance



  • @uaxero:

    Error message: disk I/O error. Remove the database file manually and try again.

    You checked the state of your disk (disk I/O error => the beginning of the end ?) ?
    Is in in some read-only mode ?
    You did what was being proposed, removing the database file manually ?



  • thanks for you reply.

    my system don´t show any error I/O.

    after of a new installation of 2.2.5 version the issue happened again.

    now with this error

    00 system log entries
    Dec 9 12:32:16 php[79470]: /index.php: Submission to captiveportal with unknown parameter zone: 1
    Dec 9 11:23:12 php: /index.php: Submission to captiveportal with unknown parameter zone:

    again the database has been delete and i have back to lost all the clients connected.

    thanks


  • Banned

    @uaxero:

    my system don´t show any error I/O.

    What? Did you read what you posted in your OP?

    
    logportalauth[18435]: Zone: xxxxx - Still unable to create tables for xxxx. Error message: disk I/O error. Remove the database file manually and try again.
    
    


  • I have the same problem after upgrading to 2.2.5.
    pfSense is running in an ESXi VM.

    After the error happened on Tuesday, the list of logged in users were empty, but the users who were logged in were still able to access the internet, and their login was not expired until I manually rebooted the server.

    Dec 10 02:42:50 logportalauth[39146]: Zone: xxx - Still unable to create tables for xxx. Error message: disk I/O error. Remove the database file manually and try again.
    Dec 10 02:42:49 logportalauth[39146]: Zone: xxx - Error during table jag creation. Error message: database is locked. Resetting and trying again.

    I upgraded pfsense a week ago, and this happened 3 times since, and never before.

    Thank you for your help



  • sorry It meant that a check of pfsense server hosted on one esx vmware server has not shown errors



  • @borbelyb:

    Bla bla bla . Error message: disk I/O error. rhon rhon rhon

    If everybody starts posting about their hardware problems (or other, related issues like "disk full" (which will be communicated as a "disk I/O error")) pfsense should open a new forum …. I propose calling it "/etc/null"

    edit : On the other hand: "Error message: database is locked." is less funny ....



  • I also have the same problem after upgrading to 2.2.5 (From both upgrade and new installation).
    And I don't think it is from I/O problem.

    ![Screen Shot 2015-12-14 at 12.01.31.png](/public/imported_attachments/1/Screen Shot 2015-12-14 at 12.01.31.png)
    ![Screen Shot 2015-12-14 at 12.01.31.png_thumb](/public/imported_attachments/1/Screen Shot 2015-12-14 at 12.01.31.png_thumb)
    ![Screen Shot 2015-12-14 at 12.00.23.png](/public/imported_attachments/1/Screen Shot 2015-12-14 at 12.00.23.png)
    ![Screen Shot 2015-12-14 at 12.00.23.png_thumb](/public/imported_attachments/1/Screen Shot 2015-12-14 at 12.00.23.png_thumb)



  • @Gertjan:

    @borbelyb:

    Bla bla bla . Error message: disk I/O error. rhon rhon rhon

    If everybody starts posting about their hardware problems (or other, related issues like "disk full" (which will be communicated as a "disk I/O error")) pfsense should open a new forum …. I propose calling it "/etc/null"

    edit : On the other hand: "Error message: database is locked." is less funny ....

    Thank you for your "kind" reply. I've tested this on the server's CARP pair, and after a few hours I got the same error. On completely different hardware. This is clearly not a hardware issue.



  • It becomes clear (as far as I can count 4 users who post about these "Error message: disk I/O error. / Error message: database is locked") very recently.

    You will find a thread were a test is going on : putting the database file on a RAM disk - not the drive.
    https://forum.pfsense.org/index.php?topic=103732.0
    https://forum.pfsense.org/index.php?topic=103707.0

    Agreed, this might not be a hardware issue, but it's not a pure software (pfsense) issue neither. Otherwise, it would show up for every one (tens of thousands) who uses the Captive Portal.



  • Probably related to this.
    https://redmine.pfsense.org/issues/5622

    which we're looking into.



  • Dear all
    I have the same problem after upgrade from 2.2.4 to 2.2.5 :-\





  • Those who are seeing this issue, please try the newest available 2.2.6 snapshot and report back. It looks to be fixed, but I would like additional confirmation.
    64 bit
    https://snapshots.pfsense.org/FreeBSD_releng/10.1/amd64/pfSense_RELENG_2_2/updates/?C=M;O=D

    32 bit
    https://snapshots.pfsense.org/FreeBSD_releng/10.1/i386/pfSense_RELENG_2_2/updates/?C=M;O=D



  • apparently now is working fine.

    after of 14 days any restart of database.

    thanks


Log in to reply