Open VM Tools



  • Very nice to have the update feature in the Alpha builds but Open VM Tools never seems work after an update.

    Tried rebooting with no luck.  Same with re-installing from the GUI.

    It always requires an uninstall and install to be detected as "Running (Guest managed)".


  • Banned



  • Thanks.  Seems the last update to that was 6 days ago.  I just updated to Nov 24 20:16:41 CST 2015 build from the one before that and still having the problem.

    I can't find any obvious errors produced during the update.  Maybe I'm not looking in the right place.


  • Banned

    Well, perhaps respond on the above linked bug if you are having the same problem as shown there. (If you have a different error that the one shown there, just file a new bug.)



  • it's still an issue.



  • I had the same issue and re-installed GLIB and it fixed itself…

    "pkg install -f glib-2.44.1_1"

    I installed my PFSense from the release iso on 11/26 and updated from there to the latest as of this writing with no correct. I even tried to re-install the package with no luck from the web UI.


  • Banned

    Well, there looks to be a symlink or two missing like

    
    /usr/local/lib/libglib-2.0.so -> /usr/local/lib/libglib-2.0.so.1
    /usr/local/lib/libglib-2.0.so.1 -> /usr/local/lib/libglib-2.0.so.0.4400.1
    
    

    or some SONAME fsckup there, no idea.

    There was some bug with stale symlinks being left over on 2.2.x, maybe too many of them are now being nuked instead.



  • It was in the obsoletedfiles list. Probably ok now, but will take a new snapshot to confirm.



  • @cmb:

    It was in the obsoletedfiles list. Probably ok now, but will take a new snapshot to confirm.

    That fixed it but I think you need another one excluded:

    
    Starting vmware_guestd.
    Shared object "libgmodule-2.0.so.0" not found, required by "vmtoolsd"
    /usr/local/etc/rc.d/vmware-guestd.sh: WARNING: failed to start vmware_guestd
    
    


  • The others should be fixed now as well.



  • Works great after upgrade to Nov 30 17:12:57 CST 2015.

    Thanks.


Log in to reply