SQUID3 - General Settings



  • Hi guys, my main pfs machine went down (seems like HDD issues)
    so i setup new one 2.2.5 AMD X64

    question is regarding SQUID 3
    Im not using transparent mode proxy, but i noticed something

    if
    -Squid General Settings
    –- Proxy Interface(s) (if nothing is selected)
    --- Allow Users on Interface (not checked)

    and
    -ACLs
    ---Allowed Subnets (added all subnets, LAN, OPT1, OPT2 etc)

    proxy is not working
    under
    status --- services
    it said it is running, but i cant open any web page.

    browser settings are set on automatically detect settings (im using WPAD with DNS)
    if i set it to no proxy, it works.

    however if
    -Squid General Settings
    --- Proxy Interface(s) (if LAN, OPT1, OPT2... are selected)
    --- Allow Users on Interface (checked)

    everything works perfect
    browser settings are set on automatically detect settings

    is it suppose to work like that or i made wrong conclusion or something.

    thanks


  • Banned

    If nothing is selected, then there's no interface to to run proxy on. The issue is that <required>tag is ignored for anything but input fields. Youd configuration makes no sense.</required>



  • thanks,
    I tried with
    -Squid General Settings
    –- Proxy Interface(s) (LAN, OPT1, OPT2, selected)
    --- Allow Users on Interface (unchecked)

    -ACLs
    ---Allowed Subnets (added  LAN, OPT1, OPT2 adresses)

    and works fine.

    sorry


  • Banned

    This should work in 2.3 for all fields marked as , meanwhile, I'll add input validations for this anyway.



  • -Squid General Settings
    –- Proxy Interface(s) (LAN, OPT1, OPT2, selected)
    --- Allow Users on Interface (unchecked)

    -ACLs
    ---Allowed Subnets (added  LAN, OPT1, OPT2 adresses)

    Not sure why you're doing it that way.  Why not just check the Allow Users on Interface box and not bother with the Allowed Subnets?  They are one and the same.


Log in to reply