WAN interface issues



  • I recently downloaded and installed pfSense 2.2.5 and installed it on Vmware Workstation.  It works fine for a while passing traffic then my Windows 7 test box will show no internet connection.  I can ping the LAN and WAN interface from the Windows 7 box but not past that DNS, nothing.  If I go into the pfSense web console and go into the WAN interface and simply click Save and Apply changes without actually modifying anything the connection comes right back up.  I've disabled any power saving options on my VMWare host.  I've unchecked the block private networks option.  I've also tried running the WAN interface with Autoselect and Default with the same issue.  Interfaces both show green in the web console.  What am I missing?

    Some configuration data:
    Vmware Workstation 12
    FreeBSD 64bit
    2 virtual network adapters, one in bridge mode (WAN 192.168.10.0/24) the other in host only mode (LAN 192.168.140.10)
    I have a Windows 7 VM on the same VMNet as the host only LAN virtual adapter using a static IP 192.168.140.11



  • I have the same config but I use Vnet2 and Vnet3 for LAN and DMZ respectively and everything works perfectly.  Perhaps try getting LAN off of VMnet1 and see if that makes any difference.

    This should have been posted in the Virtualization forum.



  • Sorry about that didn't notice the virtualization forum.  Well I think I've narrowed it down to possibly only happening when I run a ping -t to an outside address.  I let the system sit for an hour or so without running a ping and the connection was still up when I returned.  I started a continuous ping and after about 30 lines the connection dropped.  I looked under Status - Gateways and it said the Gateway was down.  I went into Diagnostics - Ping and ran a ping to the gateway (my main firewall) and it responded and the gateway came back up.  So something weird is going on between this and my main firewall.  I guess I can live with it for the purpose of evaluating pfsense, knowing eventually it won't be behind another NAT firewall.



  • I've never had that problem under Workstation or ESXi.


Log in to reply