OPT1 cannot see network



  • i have a box set up for 1 WAN and 2 LAN, and the WAN-LAN part works fine. OPT1 however doesn't see anything at all, and cannot ping pfSense but pfSense can ping the client

    WAN = 10.0.0.1/8
    OPT1 = 172.16.0.1/16
    LAN = 192.168.0.1/24

    all are static ip's. the client machine on OPT1 has a DHCP assigned address of 172.16.255.255. i have created a firewall rule for OPT1 to 'allow any any any' etc, and tried some suggestions to use manual outbound NAT rules and create another rule there, again 'allow any any any'

    if anyone can help i'd appreciate it, thanks



  • Could you show screenshots of your "interfaces"-page, and the rules for your OPT interface?



  • sure. the OPT1 interface is named 'public' btw. i've just noticed the WAN seems to think that the OPT1 interface is also a DNS server?

    ![Firewall Rules.png](/public/imported_attachments/1/Firewall Rules.png)
    ![Firewall Rules.png_thumb](/public/imported_attachments/1/Firewall Rules.png_thumb)



  • and the other one:

    ![Status Interfaces.png](/public/imported_attachments/1/Status Interfaces.png)
    ![Status Interfaces.png_thumb](/public/imported_attachments/1/Status Interfaces.png_thumb)



  • The opt1 gateway is wrong. As it's a lan nic, no gateway should entered on the opt1 config page.



  • i just had a look, it doesn't seem to be specified. or am i looking in the wrong place?

    edit: no gateway has been set in the DHCP server page either.

    ![Interfaces Optional 1 (Public).png](/public/imported_attachments/1/Interfaces Optional 1 (Public).png)
    ![Interfaces Optional 1 (Public).png_thumb](/public/imported_attachments/1/Interfaces Optional 1 (Public).png_thumb)



  • Hmm as there also is that strange dns server, i would start from scratch and only assign nic and dhcp



  • i have deleted the OPT1 interface and set it up again, and set up DHCP and the firewall rule 'any any any' again, i still don't seem to be able to connect and the odd DNS server still appears for the WAN. did you mean redo the OPT1 interface or completely start from scratch?



  • completely start from scratch



  • tried a fresh config, 2nd LAN works fine now, thank you very much for the help. i've been testing pfSense for a week or so and the support here as well as the features are most impressive.


Log in to reply