Squid Reverse Proxy - NAT Rule?



  • Good Evening,

    I have Squid & SquidGuard setup & running on LAN in Transparent Proxy mode.  Behind the firewall I have three servers: Server Essentials, Web Application Proxy, & a Web Host.  All 443 traffic is NAT'd to the Web Application Proxy & working perfectly, including remote access, backups, & active sync.  The issue I'm having is with Port 80 traffic.

    I have a dynamic IP address & the domain is hosted through DynDNS.

    I need for (Port 80) remoteaccess.domain.com to be directed to the Server Essentials machine.  All other Port 80 traffic, I need to have redirected from HTTP to HTTPS for the Web Application Proxy to handle.

    I have setup SquidReverse Proxy to listen on Port 80 & have mapped remoteaccess.domain.com correctly.  I have setup the HTTP to HTTPS redirects in the Redirect section of SquidReverse Proxy.

    I tested the setup by NAT'ing all Port 80 traffic to 127.0.0.1 & setting the Reverse Proxy to listen on the Loopback Adapter.  The reverse proxy worked as expected, however, local network clients experienced 404 errors when attempting to browse to various websites running on Port 80.

    My question is, how do I configure the NAT Rule &/or the SquidReverse Proxy Adapter given my Dynamic IP Address setup?


Log in to reply