VPN clients with no response from LAN due to routing

  • Hi all
    I am using a PFSense firewall in my company and I am facing a problem with OpenVPN. The setup is the following:


    The VPN tun server is bound to Active Directory for authentication. VLANs are used.

    VPN does not work for some users

    If an user connects everything is fine (address is assigned), if another user connects it doesn't get responses from other networks (has address
    Moreover if the server is restarted and the second user connects first it works because the address is assigned. If this address is used the client works (no matter the login), if other addresses are used it doesn't.

    I see in the routing table that an entry is always present for but not one for The VPN server says it's routing both, but it's not true. The packets arrive in the LAN but do not get routed correctly when going back. Also it's possible to ping the VPN computers from inside the firewall.

    What I already tried:

    • Reconfigure everything with the wizard
    • Check rules
    • Check and change vpn server settings
    • Enable debug logs and inspect, nothing
    • Check system logs, nothing

    At this point I kindly ask for help from users that are far more experienced on networking than me. Thanks a lot : )
    ![Screenshot 2015-12-04 11.02.20.png](/public/imported_attachments/1/Screenshot 2015-12-04 11.02.20.png)
    ![Screenshot 2015-12-04 11.02.20.png_thumb](/public/imported_attachments/1/Screenshot 2015-12-04 11.02.20.png_thumb)

  • Your VPN subnet is assigned to a VLAN???

    What is your VPN server config?

  • No, it's not assigned to a VLAN, in fact it's not even assigned to an interface.

    - <openvpn-server><vpnid>1</vpnid>
    <authmode>Active Directory</authmode>

  • Your routing table shows your VPN subnet is assigned to em0_vlan30. So please check your interface configuration or post the output of Status > Interfaces here (as screenshot!).

  • My god, you're right! I assigned the same subnet to the guest network and the VPN! I will check that again, thank you very much.

Log in to reply