Sierra MC73xx diagnostic or GPS serial working?



  • Thanks to the advice on this board plus hints on other boards about fighting through PID changes and firmware flashing for MC73xx cards (including one darn Dell locked DW5808) - I now have an MC7354 working! Thanks all.

    I would like to check signal strength on the card while the PPP connection is active. But it seems like only /dev/cuaU0.2 is working and that's taken by ppp. When I used the card in Linux and Windows; I could get responses from the diagnostic interface and read continuous data from the GPS serial interface.

    Anyone have any luck working with other serial interfaces on the MC73xx under pfsense?



  • AT Connections on MC73xx are cuaU0.3

    I have GPS on the MC73xx on my todo list.
    I have a post on the FreeBSD embedded board with Sierra MC7700 GPS setup instructions if needed.
    I have not tried GPSd on pfSense yet. Have you?

    Yell if you need any help.

    edited for accuracy



  • For GPS from your device you could try this:

    pkg install gpsd

    setup modem:
    cu -l /dev/cuaU0.2
    at
    atz
    AT!ENTERCND="A710"
    AT!CUSTOM="GPSENABLE",4

    Switch on GPS Stream on USB Port
    echo $GPS_START >/dev/cuaU0.1

    Start gpsd in forground to ensure its proper operation
    gpsd -n -N -D 4 /dev/cuaU0.1
    This will show status. Hit CTL-C to exit. If good reboot and proceed on.

    Start the daemon in background mode after $GPS_START command has been issued.
    gpsd -n /dev/cuaU0.1

    Should now be working. Checkout raw stream with gpscat /dev/cuaU0.1
    You should see streams of text on screen.
    gpsd ships with several clients and cgps is a command line based tool used to check location.

    I have not tried this yet on pfSense. Only on FreeBSD.



  • OK got this working tonight on pfSense. My instructions are spot on. Make sure you run gpsd in the forground first as it sets the hardware up.

    One little glitch is that python27 is installed as a dependency and it is not working correctly or the python environment is not set right.
    So no gpscat as it errors out, but there is another option that ships with gpsd called cgps. This is a command prompt program which shows all the info's. Numbers of Satellites, Coords, Time..all info including the incoming stream of GPS packets at the bottom of the screen.
    Run it like this cgps /dev/cuaU0.1
    -Control C- to exit.

    pfSense overlords you deserve a bow.
    Thanks So Much



  • I used pfSense 2.2.5 -32bit  memstick Full Install.
    These instructions are needed for FreeBSD pkg bootstrap.
    https://doc.pfsense.org/index.php/Installing_FreeBSD_Packages

    On pfSense 2.3 alpha it uses an pfSense repository instead of the needed FreeBSD repository. May be able to adjust pkg.conf with the FreeBSD repository. I dunno.



  • So you want to log your pfSense box to see where it has been?
    gpsd has an app for that
    gpxlogger
    This program collects fixes from gpsd and logs them to standard output in GPX, an XML profile for track logging.



  • Got it working on bootup very easily with the excellent instructions here:
    https://doc.pfsense.org/index.php/Executing_commands_at_boot_time

    This goes in your xml file per instructions:

    <shellcmd>echo $GPS_START >/dev/cuaU0.1</shellcmd>
    <shellcmd>gpsd -n /dev/cuaU0.1</shellcmd>
    <shellcmd>gpxlogger -d -f /home/gps/trip_log_date +"%Y%m%d_%H%M%S".txt -m 50</shellcmd>

    (You need to specify a log file location for gpxlogger -if used)



  • I am finally getting around to testing the MC7354/7355.
    cuaU0.1 = GPS
    cuaU0.2 = Data
    cuaU0.3 = AT console
    The AT interface works when connected as it should on MC73xx.

    My problem is on the MC7700 the interfaces AT and DATA are combined on connection rendering the AT console busy. Still connects.



  • I know this is an oldish topic, but it's the only mention I could find where GPS_START was used against cuaU0.1, where did you get this information? I can't find this in the documentation, is there a document someplace with this sort of information?  I've been trying to find ways to get access to the AT interface while still in use, I know not to touch the DATA port, if I'm using it.

    and on Pfsense 2.3.1 release P5, it seems my MC7354 is also sharing AT and DATA on cuaU0.2 when the data should be the cuaU0.2 and AT console on cuaU0.3, but I can't find documentation on where these should be.  Is this a matter of "reading the kernel module source" ? or is this somehow hidden in the manual someplace?



  • Wondering if my issue is related.  I have an MC7700 and trying to get GPS to work with the NTP server on pfSense.  I dont seem to be able to get NTP to see GPS data on any of the ports.  LTE on 0.3 works fine.  Nothing else though.


Log in to reply