Squid won't append suffix to single label names



  • I'm using non-transparent proxy.

    If I try to ping "site" from my freeBSD box, my DNS server gets a query for "site.domain.local", and the ping command works just fine.

    If I try to open "site" from my browser, squid tells me that the name could not be resolved, and my DNS server gets a query for "site", instead of "site.domain.local".

    I know there are other ways around this, but I want to know specifically whether there is a way to make squid append a default suffix to every single label name.

    My resolv.conf is as follows:
    search domain.local
    nameserver 172.16.10.1
    nameserver 172.16.10.2



  • The append_domain directive might be what you need:

    http://www.squid-cache.org/Doc/config/append_domain/



  • I'm pretty sure I had already tried this before, but I must have done something wrong, because it didn't work back then.
    Anyway, now it works fine. Thanks. Is there a better place to put this config other than in:
    Services -> Squid Proxy Server -> General -> Advanced Features -> Integrations

    ?



  • Nope, that's the place.  Glad to hear you got it working.


Log in to reply