Zotac ZBOX CI323 nano



  • @IggyB:

    hi
    sorry haven't checked the forums in a while
    for the guy who asked for it

    http://s000.tinyupload.com/?file_id=67950169242632494971

    that's the compiled version i use on my pfSense 2.3.2

    compiled on FreeBSD 10.3

    I tried following your instructions, but couldn't locate the driver on Realtek's site.

    I think it's the one listed under:

    Network Interface Controllers
    10/100/1000M Gigabit Ethernet
    PCI Express <–- Is this correct?

    http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

    Unix (Linux)
    Apply to RTL8111H(S)/RTL8118/RTL8119i as well.
    Description Version Update
    FreeBSD 7.x and 8.0
    1.93 2017/2/13 83k

    Is the above mentioned 1.93 file under Unix/FreeBSD 7.x and 8.0 what I need to get to continue with the rest of the compile steps?

    EDIT: Was able to get some help compiling the 1.93 Realtek PCI-E driver above. Seems to work without issue (so far) and I verified it was loaded.



  • There is a new generation out with an Apollo Lake processor, but still Realtek-NICs.

    https://www.zotac.com/us/product/mini_pcs/ci327-nano



  • I hate to hijack this thread, but can anyone explain the process for getting pfSense installed on one of these boxes? It seems to get installed and sits at the f1 prompt, but goes into a reboot loop after the install. If you want to break this out into its own thread be my guest.

    Thanks



  • Sounds like you need to change your bios from UEFI to Legacy.

    @Rockn:

    I hate to hijack this thread, but can anyone explain the process for getting pfSense installed on one of these boxes? It seems to get installed and sits at the f1 prompt, but goes into a reboot loop after the install. If you want to break this out into its own thread be my guest.

    Thanks



  • does 2.3.4 have the latest realtek driver update?



  • Any update on the onboard wifi card if that works with PFsense?
    I am about to pull the trigger on buying on of these, but would really like to know if the onboard wifi is recognized by Pfsense.



  • I have one of these since a couple of months.

    Never ever managed to get full gigabit nat perfomance.

    No KVM Virtio perfomance with openwrt(750 mbits)
    No Esxi VMXNET3 performance with openwrt(650 mbits)
    Tried opnsense on baremetal (500 or 300 mbits)
    Never tried pfsense since their lack of support  for my pppoe connection

    all the speeds are WAN to LAN troughput on a PPPoE FTTH connection(1000/200)

    Same tests on a virtualized environment with G4560 CPU and intel nics are all full gigabit speed



  • @silvan_0172:

    Any update on the onboard wifi card if that works with PFsense?
    I am about to pull the trigger on buying on of these, but would really like to know if the onboard wifi is recognized by Pfsense.

    Installed latest version 2.3.4 yesterday and wireless card is not recognized.



  • Installed latest version 2.3.4 yesterday and wireless card is not recognized.

    Add these two lines in /boot/loader.conf

    legal.intel_iwi.license_ack=1
    legal.intel_ipw.license_ack=1



  • There is a new driver on Realtek's site v.193 with included patches. Work's on 2.3.4

    If you want to compile your own on FreeBSD 10.3

    1. update the driver source code:
                        Remove existing if_re.c from /usr/src/sys/dev/re or rename to if_re.c.org
        Copy the new 1.93 dirver source code( if_re.c and if_rereg.h) into /usr/src/sys/dev/re
                        Remove existing Makefile from /usr/src/sys/modules/re or rename to Makefile.org
        Copy the new 1.93 Makefile into /usr/src/sys/modules/re

    2. build the driver:

    cd /usr/src/sys/modules/re

    make clean

    make

    3. Upload the new if_re.ko from /usr/src/sys/modules/re to your pfSense box in /boot/kernel
                            # cd /boot/kernel
                            # chmod 0555 if_re.ko
    '                      # chown root:wheel if_re.ko
                              edit /boot/loader.conf in pfSense with vi
                              add line add line if_re_load="YES"
                            # reboot

    Don't forget to rename old .ko module if you want to keep it or remove it



  • Hi @cinnamon

    are you able to compile the latest driver?  not got freebsd.

    thanks very much



  • What pfsense ver are you using?



  • I have the CI327 and was also having throughput and timeout problems. I was able to resolve my problems by compiling 1.93 in a VM running FreeBSD 11. I copied the driver over to my pfSense box and no more timeouts. I disabled all the tuning options that I had previously applied and it still works fine. Before I went this route I couldn't get anything over 50MBit/Sec. Now I am maxing out my 100Mb/100Mb connection.

    The process was very straight forward too. Make sure when installing FreeBSD 11 for your build environment that you select the option to install the source tree. Then do a "pkg install curl" and then follow these directions:

    On Build Server:
    curl -o /tmp/rtlv193.tgz http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0006-rtl_bsd_drv_v193.tgz
    tar -xf /tmp/rtlv193.tgz -C /tmp/
    
    cp /tmp/rtl_bsd_drv_v193/if_re* /usr/src/sys/dev/re/
    cp /tmp/rtl_bsd_drv_v193/Makefile /usr/src/sys/modules/re/
    cd /usr/src/sys/modules/re/
    make
    
    scp /usr/src/sys/modules/re/if_re.ko root@<pfsenseip>:/boot/kernel/
    
    On pfSense:
    cd /boot/kernel
    chmod 0555 if_re.ko
    chown root:wheel if_re.ko
    
    Add this line to /boot/loader.conf.local:
    if_re_load="YES"
    
    reboot pfsense
    
    After reboot verify that it loaded the new driver with:
    dmesg | grep re0</pfsenseip>
    

    Edit: One other problem I had on the CI327 was boot time took forever due to it trying to access the SD card reader. I was able to resolve this by hitting ESC at the boot loader (from the install media) and then typing:

    
    set hint.sdhci_pci.0.disabled=1
    set hint.sdhci_pci.1.disabled=1
    boot
    

    Then at the end of the install it prompts you about going to a shell to make additional changes. Say yes and then add these lines to /boot/loader.conf.local:

    
    hint.sdhci_pci.0.disabled=1
    hint.sdhci_pci.1.disabled=1
    
    

    This was all done on pfSense 2.4 nightly.



  • @cinnamon:

    Installed latest version 2.3.4 yesterday and wireless card is not recognized.

    Add these two lines in /boot/loader.conf

    legal.intel_iwi.license_ack=1
    legal.intel_ipw.license_ack=1

    Just added this and still doesn't work.



  • @cinnamon:

    There is a new driver on Realtek's site v.193 with included patches. Work's on 2.3.4

    If you want to compile your own on FreeBSD 10.3

    1. update the driver source code:
                        Remove existing if_re.c from /usr/src/sys/dev/re or rename to if_re.c.org
        Copy the new 1.93 dirver source code( if_re.c and if_rereg.h) into /usr/src/sys/dev/re
                        Remove existing Makefile from /usr/src/sys/modules/re or rename to Makefile.org
        Copy the new 1.93 Makefile into /usr/src/sys/modules/re

    2. build the driver:

    cd /usr/src/sys/modules/re

    make clean

    make

    3. Upload the new if_re.ko from /usr/src/sys/modules/re to your pfSense box in /boot/kernel
                            # cd /boot/kernel
                            # chmod 0555 if_re.ko
    '                      # chown root:wheel if_re.ko
                              edit /boot/loader.conf in pfSense with vi
                              add line add line if_re_load="YES"
                            # reboot

    Don't forget to rename old .ko module if you want to keep it or remove it

    I don't quite understand why each should compile the driver, since we're all going to be using it on the same hardware.
    Do you happen to have the 1.93 driver already compiled? Attaching it here would be of great help for many strugling to get the wan stable. I know I am…
    Just add .txt to the end of the file and attach it here.
    Thanks!
    p.s. I did try to compile it in a virtual freebsd 11.0 and the resulting module is not loaded by pfsense.



  • @cinnamon:

    hi
    sorry haven't checked the forums in a while
    for the guy who asked for it

    http://s000.tinyupload.com/?file_id=67950169242632494971

    that's the compiled version i use on my pfSense 2.3.2

    compiled on FreeBSD 10.3

    This seems to have worked. I'll attach it here in case the link goes down.
    Also I'd love v1.93. As I understand the one I attached is v1.92

    if_re.ko.txt



  • This is v1.93 that I tried briefly on 2.4 beta (freebsd 11) before finding out that I couldn't receive IPv6 from the WAN.

    if_re.zip



  • @cinnamon:

    Hey sorry, just got my main desktop up and running. I had some trouble after draining my watercooling loop, had to go out and buy a new block. then my pumps reservour cracked. etc.. lol

    1. Install Kernel FreeBSD 10.3 with kernel sources.
    1. Get kernel  driver 1.91 from realtek site. You don't need the patch for driver, only if you're using FreeBSD 11+
    2. Modify /usr/src/sys/amd64/conf/GENERIC and delete line "device re" - so if_re no longer be included in kernel itself - module will be build anyway.
    3. Edit /boot/loader.conf adding line if_re_load="YES", so external module will be loaded.
    4. Go to /usr/src and run "make buildkernel KERNCONF=GENERIC && make installkernel KERNCONF=GENERIC"
    5. Reboot with new kernel. System should boot with open-source driver as module. kldstat will show if_re in list of modules.
    6. Put Realtek's if_re.c and if_rereg.h into /usr/src/sys/dev/re
    7. Build driver (cd /usr/src/sys/modules/re && make clean && make)
    8. Backup /boot/kernel/if_re.ko, then cp /usr/src/sys/modules/re/if_re.ko /boot/kernel/if_re.ko && chmod 0555 /boot/kernel/if_re.ko && chown root:wheel /boot/kernel/if_re.ko
    9. Reboot

    Now i wasn't sure how to upload files to internet using lynx or fetch so i installed xorg server and kde on vm FreeBSD. This took a while and i had some issues with timeouts etc.
    Basicly i uploaded new compiled if_re.ko to some small file hosting sites, used a tinyurl to shorten it with direct link

    SSH into pfSense and used fetch to download it into /boot/kernel/
    chmod 0555 /boot/kernel/if_re.ko && chown root:wheel /boot/kernel/if_re.ko

    edit /boot/loader.conf in pfSense. Can do through web browser or through ssh client with vi
    add line if_re_load="YES"

    That should be it. Reboot and your 1.92 should be loaded. If you want to unload it just put # infront of if_re_load="YES" in /boot/loader.conf
    If you're having issues compiling or uploading to web/usb stick i will be happy to upload it for you or send you somehow a already compiled one

    I downloaded the compiled module from a few posts down the thread and installed with these instructions.

    In my limited testing, this HAS fixed my issues with the CI323 nic's when downloading large files across my FIOS 300/300 service.

    THANK YOU!



  • 1.93 works fine on 2.4-RC. I have IPv6 working on mine too. Throughput still isn't consistent. It maxes out my 100/100 fiber but it seems to randomly hang on speed tests here and there.

    I posted directions on compiling and installing along with all the loader options that are needed in this post here:
    https://forum.pfsense.org/index.php?topic=103841.msg739039#msg739039



  • I run a CI323 nano and just updated to 2.4.0-RELEASE.  As part of that, I grabbed Realtek's latest driver (v1.94 released September 15, 2017) from here:  http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

    I then grabbed a ready-to-run FreeBSD 11.1 VM image here:  https://download.freebsd.org/ftp/releases/VM-IMAGES/11.1-RELEASE/amd64/Latest/FreeBSD-11.1-RELEASE-amd64.vmdk.xz and fired it up in Virtualbox.  The compilation went right through with no patching or modifications required.  All I had to do then was put the compiled if_re.ko module in /boot/kernel/ and add the line if_re_load="YES" to /boot/loader.conf.local and everything seems to be happy, at least as evidenced by if_re.ko being listed in the output from kldstat and no stability issues so far.

    I've added the compiled module in case anyone else wants it.  The SHA512 of the if_re.ko file (not the ZIP file) is:
    00f0278b396844e2735d10b57780ccf31a085d9a52e9e192fb758a904172fa4a9c27da297f6722f69906d9d62f4168ea3babfc8a27849f37a667bc0323c1841b

    if_re.ko.zip



  • @TheNarc:

    I run a CI323 nano and just updated to 2.4.0-RELEASE.  As part of that, I grabbed Realtek's latest driver (v1.94 released September 15, 2017) from here:  http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

    I then grabbed a ready-to-run FreeBSD 11.1 VM image here:  https://download.freebsd.org/ftp/releases/VM-IMAGES/11.1-RELEASE/amd64/Latest/FreeBSD-11.1-RELEASE-amd64.vmdk.xz and fired it up in Virtualbox.  The compilation went right through with no patching or modifications required.  All I had to do then was put the compiled if_re.ko module in /boot/kernel/ and add the line if_re_load="YES" to /boot/loader.conf.local and everything seems to be happy, at least as evidenced by if_re.ko being listed in the output from kldstat and no stability issues so far.

    I've added the compiled module in case anyone else wants it.  The SHA512 of the if_re.ko file (not the ZIP file) is:
    00f0278b396844e2735d10b57780ccf31a085d9a52e9e192fb758a904172fa4a9c27da297f6722f69906d9d62f4168ea3babfc8a27849f37a667bc0323c1841b

    I can confirm this works, thank you, guess i better start learning how to compile these realtek drivers since my old if_re.ko for the previous version of pfsense 2.3 didnt work anymore for pfsense 2.4  :-\



  • Has everyone done the upgrade from 2.3.x to 2.4? Or is it better to start from scratch and enable ZFS?



  • I ran the upgrade, which completed fine.  However, I also run the pfBlockerNG package and there have been reports that it will cause lockups unless you update to ZFS.  I haven't had this happen (yet) on my system so I haven't read up on it too much, but here's the thread in case you're interested:  https://forum.pfsense.org/index.php?topic=137103.0



  • is 2.4 working on this box properly?



  • It seems to be working fine for me, at least using Realtek's v1.94 driver.  Of course, since 2.4.0 has been out for less than a week it's impossible to say whether it's completely stable yet.



  • someone needs to make a youtube video of how-to do this…lol

    ok i think i got it. seems to be ok

    anyone else having success?



  • Thanks to TheNarc- got the module and loaded it up.
    So far, so good but it's only been a day so..

    Edit- so…given that the normal FreeBSD drivers for Realtek NICs are not up to par, is there any reason we can't load up a kernel module in pfSense by default (question to the devs)? Is there some kind of issue loading up realtek drivers in the module due to copyright, openness, etc.? Figured you could just grab one of the latest, have beta testers test it, then keep it for the length of the FreeBSD base (ie. same driver/kernel module all the way through FreeBSD11, then upgrade the driver when it goes to 12, etc.)



  • Is this still ok to use on 2.4.1 ? Should be since we are still FreeBSD 11. Or do I need to recompile?



  • @silviu:

    Is this still ok to use on 2.4.1 ? Should be since we are still FreeBSD 11. Or do I need to recompile?

    No issues here with that 1.94 module linked above.



  • 1.94 seems to help Zotac CI327 too in terms of gaining stability and network performance when running pfsense 2.4.1.

    So thanks to all those who figured out and provided the solution and especially for the binary.

    I wonder if it would also benefit 2.3.x (FreeBSD 10.3).
    Anyone has used it with 2.3.x ?



  • Thanks to (among others) Ermax, Cinnamon, TheNarc and a little Google this noob was able to almost max out my 400/40 line on the C1327 nano with 2.4.1-RELEASE. Next stop: learn to speak FreeBSD… :o



  • Hi!

    I have also the ZBOX CI323 nano and the wireless is not working with pfsense 2.4.1. I added the two lines to /boot/loader.conf:

    
    ...
    legal.intel_iwi.license_ack=1
    legal.intel_ipw.license_ack=1
    
    

    The output from pciconf -lv:

    
    ...
    none2@pci0:4:0:0:       class=0x028000 card=0x80708086 chip=0x08b38086 rev=0x83 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'Wireless 3160'
        class      = network
    
    

    I assume the missing subclass (Wireless) is responsible for not showing up in the wireless section. Is there any possibility to make it working though?



  • My CI327's wifi card was not supported by FreeBSD 10.3 or 11.1, but in an old laptop I found a wifi card that agreed with FreeBSD, so I swapped them.
    The laptop (running linux) figured out the proper driver in a heartbeat so the new card didn't go to waste. On the pfsense box, the legacy wifi card supports G only, but better than nothing.
    You might want to try something similar or even buy a suitable wifi card for your pfsense box. Wifi troubleshooting is way too painful especially on a FreeBSD system.



  • @TheNarc:

    I run a CI323 nano and just updated to 2.4.0-RELEASE.  As part of that, I grabbed Realtek's latest driver (v1.94 released September 15, 2017) from here:  http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

    I then grabbed a ready-to-run FreeBSD 11.1 VM image here:  https://download.freebsd.org/ftp/releases/VM-IMAGES/11.1-RELEASE/amd64/Latest/FreeBSD-11.1-RELEASE-amd64.vmdk.xz and fired it up in Virtualbox.  The compilation went right through with no patching or modifications required.  All I had to do then was put the compiled if_re.ko module in /boot/kernel/ and add the line if_re_load="YES" to /boot/loader.conf.local and everything seems to be happy, at least as evidenced by if_re.ko being listed in the output from kldstat and no stability issues so far.

    I've added the compiled module in case anyone else wants it.  The SHA512 of the if_re.ko file (not the ZIP file) is:
    00f0278b396844e2735d10b57780ccf31a085d9a52e9e192fb758a904172fa4a9c27da297f6722f69906d9d62f4168ea3babfc8a27849f37a667bc0323c1841b

    My apologies for this very amateur hour question, but how do I do this with my Zotac box? I've got version 2.4.1 running great, but obviously I'm getting the "re0:watchdog timeout" with the drivers that came with the box. Updating the drivers seems to be the best chance (the interface dies every few hours…). I tried uploading the files from both the GUI and the command prompt during loading and can't figure it out.

    The very, very gracious if_re.ko file that you provided is unzipped and on a USB drive, but I can't figure out how to move that to the /boot/kernel folder; I've been trying the "mount /dev/da0s1a /mnt" command from the 'execute shell command' in the GUI but...no joy. I can add the text line in /boot/loader.conf.local no problem using the Diagnostics/Edit File in the GUI.

    Thanks for your help! Hopefully this will fix this Realtek issue once and for all for me.

    EDIT: well regrettably wasn't able to get anyone here to help me out with the issue, but another forum suggested using WinSCP to get the file over to the box; that worked perfectly and was very intuitive (for even me) to use. So if anybody is as clueless as I am, that tool is a great way/GUI to connect to your pfSense box and move files around between Windows & Unix/FreeBSD/pfSense.



  • @MuadDib81:

    Hi!

    I have also the ZBOX CI323 nano and the wireless is not working with pfsense 2.4.1. I added the two lines to /boot/loader.conf:

    
    ...
    legal.intel_iwi.license_ack=1
    legal.intel_ipw.license_ack=1
    
    

    The output from pciconf -lv:

    
    ...
    none2@pci0:4:0:0:       class=0x028000 card=0x80708086 chip=0x08b38086 rev=0x83 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'Wireless 3160'
        class      = network
    
    

    I assume the missing subclass (Wireless) is responsible for not showing up in the wireless section. Is there any possibility to make it working though?

    I just ended up purchasing a cheap ($20) wireless D-Link access point for my home as a "workaround". It is great. I have the WAN as re0 and LAN as re1 going to the wireless device configured with a static IP. The pfSense does the routing/DHCP…and the D-Link is just an access point. You might want to consider a solution like that rather than using an internal NIC. Its tough to find anybody on this forum that supports using internal NICs as your home WAP.



  • Sorry guys but I'm new to freeBSD (actually I'm just a user with no experience in compiling stuff)… is there any guide to put this driver in my pfsense installation?

    I've got the Zotac CI323 and I can only go up to 100tx on my LAN despite everything else is gigabit... hope the diver can help..

    thanks, Max



  • Apologies to bgbird03; I don't check the forums as often as I should.  But the WinSCP solution referred to by him/her is probably the path of least resistance for getting the if_re.ko file to the /boot/kernel/ location on your pfSense machine from a Windows machine.  Here's a decent write-up with a link to download WinSCP that should still work even though it was written in 2010:  https://dave.harris.uno/using-winscp-to-connect-to-pfsense/.  Once you have the file up, you may need to set its permissions and/or ownership; in any case, it's a good idea.  The easiest way to do this from a Windows machine is probably using putty.  Here's a decent guide on that:  https://turbofuture.com/internet/How-to-Access-pfSense-Remotely-Using-SSH.  Note that you only need to follow it as far as "The Console Menu."  Once you have a command prompt after entering 8 at the options menu, execute the following two commands:
    chown root:wheel /boot/kernel/if_re.ko
    chmod 0555 /boot/kernel/if_re.ko
    After this, if you execute:
    ls -al /boot/kernel/if_re.ko
    You should see output like this:
    -r-xr-xr-x  1 root  wheel  522968 Oct 12 19:51 /boot/kernel/if_re.ko

    After that, you just need to tell the system to load and use this module.  To do that, go to the normal pfSense web interface and navigate to Diagnostics > Edit File.  Type in /boot/loader.conf.local and click Load.  At the end of anything already there, add the line:
    if_re_load="YES"

    I also have these lines, which I found some time ago in this thread:  https://forum.pfsense.org/index.php?topic=101587.0.  Full disclaimer, I don't know whether they're really necessary or helpful, but I've had them forever on my CI323 and they certainly don't cause any trouble . . .
    hw.re.msi_disable=1
    hw.pci.enable_msix=0
    hw.pci.enable_msi=0

    So that ought to do it.  Obviously you'll need to reboot your pfSense machine for the changed to take effect.  If you want to verify the new module is being used, SSH in again using putty and run:
    kldstat

    You'll probably get a few lines of output from this, but one of them should list if_re.ko.



  • @TheNarc:

    Apologies to bgbird03; I don't check the forums as often as I should.  But the WinSCP solution referred to by him/her is probably the path of least resistance for getting the if_re.ko file to the /boot/kernel/ location on your pfSense machine from a Windows machine.  Here's a decent write-up with a link to download WinSCP that should still work even though it was written in 2010:  https://dave.harris.uno/using-winscp-to-connect-to-pfsense/.  Once you have the file up, you may need to set its permissions and/or ownership; in any case, it's a good idea.  The easiest way to do this from a Windows machine is probably using putty.  Here's a decent guide on that:  https://turbofuture.com/internet/How-to-Access-pfSense-Remotely-Using-SSH.  Note that you only need to follow it as far as "The Console Menu."  Once you have a command prompt after entering 8 at the options menu, execute the following two commands:
    chown root:wheel /boot/kernel/if_re.ko
    chmod 0555 /boot/kernel/if_re.ko
    After this, if you execute:
    ls -al /boot/kernel/if_re.ko
    You should see output like this:
    -r-xr-xr-x  1 root  wheel  522968 Oct 12 19:51 /boot/kernel/if_re.ko

    After that, you just need to tell the system to load and use this module.  To do that, go to the normal pfSense web interface and navigate to Diagnostics > Edit File.  Type in /boot/loader.conf.local and click Load.  At the end of anything already there, add the line:
    if_re_load="YES"

    I also have these lines, which I found some time ago in this thread:  https://forum.pfsense.org/index.php?topic=101587.0.  Full disclaimer, I don't know whether they're really necessary or helpful, but I've had them forever on my CI323 and they certainly don't cause any trouble . . .
    hw.re.msi_disable=1
    hw.pci.enable_msix=0
    hw.pci.enable_msi=0

    So that ought to do it.  Obviously you'll need to reboot your pfSense machine for the changed to take effect.  If you want to verify the new module is being used, SSH in again using putty and run:
    kldstat

    You'll probably get a few lines of output from this, but one of them should list if_re.ko.

    TheNarc: you're amazing! You've already done a ton by compiling the driver and posting it, so yeah, I don't blame you if you don't live on the forum 24/7. Your debt to society has been paid in my opinion…

    Putty'd in no problem and changed the permissions like you said (my time stamp is slightly different, but whatever -- good enough for me). Edit file was super easy also. I had seen most of those lines before -- seems like every Zotac box of this type needs them? -- and added the hw.re.msi_disable=1 because I didn't have that one. And...of course it caused my boot to hang at some random thing...atrtc0, right above some "event timer". I rebooted, pushed option 3, set hw.re.msi_disable=0, and everything booted fine. So henceforth, I deleted that from mine. No idea why my box didn't like it.

    Rebooted and verified with kldstat that if_re.ko is indeed running. Also did a dmesg and after hunting around for it, found my re0 & re1 version was 1.94.01, so I'm assuming things went as planned.

    Will this driver work with future version of pfSense? Like when they move to FreeBSD 12.0 or whatever (in the future?) Just kind of curious. I think the solution is to probably move away from a Realtek NIC, but for the moment I wanted a cheap project to play around with and learn simple firewall/unix stuff, and this box really fit the (low power) bill.

    It seems to have fixed my watchdog timeout error. Now if only I could get my PS4 to stop having massive lag! Again -- thanks for your help on this very specific issue.



  • Nice!  Thanks for the kind words and glad this worked for you.  Not sure about that hw.re.msi_disable option; honestly I haven't really looked into exactly what it does.  But of course the important thing is getting rid of the timeout errors.  As far as forward-compatibility, I would sort of expect we'll need to (or at a minimum should) recompile again for the next major FreeBSD release (e.g. 12.0) but that what we have now should work for any minor releases of FreeBSD 11.  That kind of compatibility question really depends on how OS releases are managed, and I'm not a BSD guru.  But I think it's a reasonable expectation, in roughly the same way that you would expect a driver for Windows 7 to work regardless of what service pack you're on, but not necessarily that the same driver would work for Windows 10.  Although I'll be glad to recompile for FreeBSD 12.0 whenever pfSense transitions to it.



  • Interesting followup to the hw.re.msi_disable=1 that you had in the loader.conf.local. If you remember, I put that in, it "broke" the boot, so took it out and it worked fine. Well…when I upgraded to 2.4.2 today, it for some reason got stuck in the exact same spot (even though hw.re.msi_disable=1) wasn't in the loader.conf.local. So...I manually set it to hw.re.msi_disable=0 before the boot process using option 3, and that fixed it. I've now added hw.re.msi_disable=0 to the loader.conf.local permanently; just interesting that it is the exact opposite setting of what you have.


Log in to reply