OpenVPN tunnel network ip the same with lan



  • Hi All,

    I am facing an issue with the setup of OpenVPN package.

    First of all I would like to indicate that pfSense runs inside a VMWare ESXi hypervisor. pfSense has two interfaces, LAN and WAN. WAN has a static IP (accesisble from everywhere) assigned to it and LAN virtual machines have specific IPs assigned to them in 10.0.0.0/24.

    In one of the machines there is a software we need to access remotely (ARIS Business Server). This software uses CORBA for communication and it doesn't work under NAT. That's why although I have correctly configured NAT in pfSense this specific software does not work. Based on the above I configured OpenVPN in order to get a local IP and be able to connect to the software. Configuring the OpenVPN I specified that the tunnel interface should be in 10.0.8.0/24. With that setup I was able to connect to the OpenVPN server and ping successfully other VMs as well as connecting to pfSense's web interface. Unfortunately I wasn't able to connect to ARIS Business server and I assumed that this might be due to the translation between 10.0.8.6 (the IP I am getting through VPN) and 10.0.0.4 (the IP ARIS Business Server is operating). Changing tunnel interface to be in 10.0.0.0/24 allows me to connect remotely to the server, however now I am receiving a host unreachable message whenever I am trying to ping any of the VMs. Moreover pfSense's web interface is not reachable.

    Any ideas on why this fails?

    Thank you in advance.


Log in to reply