Quagga OSPF PF2.2.5 Не поднимается сервис (Решено)



  • Доброго времени суток, настраиваю пакет Quagga OSPF.
    Есть два филиала, по два провайдера с каждой стороны, на головном 2 openvpn сервера, на филиале два openvpn клиента через интерфейс балансировки трафика.
    Оба клиента соединяются с серверами. Сеть филиала я вижу. При настройке поверх этого OSPF столкнулся с тем, что на обоих Pfsense 2.2.5 не стартует сервис Quagga OSPFd при этом Quagga Zebra стартует.

    При попытке запустить сервис в логах появляется запись:

    Dec 15 13:56:00 zebra[86896]: Vty connection from ::1
    Dec 15 13:56:08 zebra[65636]: Zebra 0.99.23.1 starting: vty@2601
    Dec 15 13:56:08 ospfd[65951]: ASBR[Status:1]: Update

    Настраивал по статье "OpenVPN PSK: Site-to-Site инструкция для обсуждения"
    https://forum.pfsense.org/index.php?topic=58846.0

    Какие логи, скрины нужны чтобы понять, что я делаю не так?

    Заранее спасибо. Поиск ничего не дал.



  • В Quagga OSPFd сначала необходимо настроить Interface Settings, а уже потом настраивать и сохранять Global Settings. Это первое, что приходит на ум, после описания вашей проблемы. Покажите обе эти вкладки.



  • а вы ipv6 пользуете? он же на ло интерфейсе запускается, только почему то ipV6 ом.



  • Вот скрины, порыл мануалов, может сам что то упустил, но уже впечатление, что банально квага на этом релизе не пашет(((

    ![Server int.jpg](/public/imported_attachments/1/Server int.jpg)
    ![Server int.jpg_thumb](/public/imported_attachments/1/Server int.jpg_thumb)
    ![Server int1.jpg](/public/imported_attachments/1/Server int1.jpg)
    ![Server int1.jpg_thumb](/public/imported_attachments/1/Server int1.jpg_thumb)
    ![Server int2.jpg](/public/imported_attachments/1/Server int2.jpg)
    ![Server int2.jpg_thumb](/public/imported_attachments/1/Server int2.jpg_thumb)
    ![Server global.jpg](/public/imported_attachments/1/Server global.jpg)
    ![Server global.jpg_thumb](/public/imported_attachments/1/Server global.jpg_thumb)
    ![Sever services.jpg](/public/imported_attachments/1/Sever services.jpg)
    ![Sever services.jpg_thumb](/public/imported_attachments/1/Sever services.jpg_thumb)
    ![client int.jpg](/public/imported_attachments/1/client int.jpg)
    ![client int.jpg_thumb](/public/imported_attachments/1/client int.jpg_thumb)
    ![client int1.jpg](/public/imported_attachments/1/client int1.jpg)
    ![client int1.jpg_thumb](/public/imported_attachments/1/client int1.jpg_thumb)
    ![client int2.jpg](/public/imported_attachments/1/client int2.jpg)
    ![client int2.jpg_thumb](/public/imported_attachments/1/client int2.jpg_thumb)
    ![client global.jpg](/public/imported_attachments/1/client global.jpg)
    ![client global.jpg_thumb](/public/imported_attachments/1/client global.jpg_thumb)
    ![client services.jpg](/public/imported_attachments/1/client services.jpg)
    ![client services.jpg_thumb](/public/imported_attachments/1/client services.jpg_thumb)



  • Там в Disable Redistribution нужно сети указывать, а не адреса. Т. е. 172.16.21.0/24 например, а не просто 172.16.21.0. Ну и лучше конечно вообще туда ничего не заносить. Снять галку Redistribute connected subnets и во вкладке Interface Settings просто добавить интерфейсы, сети которых необходимо распространять по OSPF. В настройках этих интерфейсов поставить галку Interface is Passive, если в их сетях нет других маршрутизаторов с OSPF.



  • Большое спасибо.
    Завелось. Виной всему моя невнимательность.


Log in to reply