[specific package] After update from 2.2 to 2.3 , can not uptade squid or delete



  • scenario :
    after updating the squid version 2.2.5 to 2.3 I can not update it. The following log:

    >>> Installing pfSense-pkg-squid... 
    Checking integrity... done (0 conflicting)
    The following 14 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	pfSense-pkg-squid: 0.4.7 [pfSense]
    	squid_radius_auth: 1.10 [pfSense]
    	squid: 3.5.9_1 [pfSense]
    	krb5: 1.13.2_3 [pfSense]
    	cyrus-sasl: 2.1.26_12 [pfSense]
    	perl5: 5.20.3_8 [pfSense]
    	squidclamav: 6.13 [pfSense]
    	c-icap: 0.3.5_2,2 [pfSense]
    	c-icap-modules: 0.3.2_4 [pfSense]
    	clamav: 0.98.7 [pfSense]
    	unzoo: 4.4_2 [pfSense]
    	arc: 5.21p [pfSense]
    	lha: 1.14i_6 [pfSense]
    	arj: 3.10.22_4 [pfSense]
    
    The process will require 75 MiB more space.
    [1/14] Installing unzoo-4.4_2...
    [1/14] Extracting unzoo-4.4_2: .. done
    [2/14] Installing arc-5.21p...
    [2/14] Extracting arc-5.21p: ...... done
    [3/14] Installing lha-1.14i_6...
    [3/14] Extracting lha-1.14i_6: .. done
    [4/14] Installing arj-3.10.22_4...
    [4/14] Extracting arj-3.10.22_4: .......... done
    [5/14] Installing krb5-1.13.2_3...
    [5/14] Extracting krb5-1.13.2_3: .......... done
    [6/14] Installing cyrus-sasl-2.1.26_12...
    *** Updated user `cyrus'.
    [6/14] Extracting cyrus-sasl-2.1.26_12: .......... done
    [7/14] Installing perl5-5.20.3_8...
    [7/14] Extracting perl5-5.20.3_8: 
    pkg: archive_read_extract(): Can't create '/usr/local/lib/perl5/5.20/AnyDBM_File.pm'
    [7/14] Extracting perl5-5.20.3_8... done
    [7/14] Deleting files for perl5-5.20.3_8: .......... done
    >>> Cleaning up cache... done.
    Success
    

    If I try to delete it, return error stating that the package does not exist (I think it has been renamed, something that)

    ERROR: Package pfSense-pkg-squid is not installed
    Failed
    
    


  • someone confirme it ?


  • Banned

    And the question is? As you can see from the log, the installed stopped half-way, for some reason claiming "success".  You can see exactly which packages got installed, pfSense-pkg-squid is not among them.



  • @doktornotor:

    And the question is? As you can see from the log, the installed stopped half-way, for some reason claiming "success".  You can see exactly which packages got installed, pfSense-pkg-squid is not among them.

    and about tentative of delete the package ?

    i cann't delete , install or reinstall squid .


  • Banned

    You cannot delete something that wasn't installed, obviously.



  • @doktornotor:

    You cannot delete something that wasn't installed, obviously.

    also , i can't install and delete squid , bcuz its said  is instaleed  :o


  • Banned

    Where it says it's installed?



  • here


  • Banned

    1/ Did you read the notes below? ("Package is configured but not (fully) installed")
    2/ Anything wrong with the reinstall button?



  • 1/ Did you read the notes below? ("Package is configured but not (fully) installed")

    yeahhh , i understand that  ::)

    2/ Anything wrong with the reinstall button?

    reinstall button , give me this  ( i already said it  ) :

    >>> Installing pfSense-pkg-squid... 
    Checking integrity... done (0 conflicting)
    The following 14 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	pfSense-pkg-squid: 0.4.7 [pfSense]
    	squid_radius_auth: 1.10 [pfSense]
    	squid: 3.5.9_1 [pfSense]
    	krb5: 1.13.2_3 [pfSense]
    	cyrus-sasl: 2.1.26_12 [pfSense]
    	perl5: 5.20.3_8 [pfSense]
    	squidclamav: 6.13 [pfSense]
    	c-icap: 0.3.5_2,2 [pfSense]
    	c-icap-modules: 0.3.2_4 [pfSense]
    	clamav: 0.98.7 [pfSense]
    	unzoo: 4.4_2 [pfSense]
    	arc: 5.21p [pfSense]
    	lha: 1.14i_6 [pfSense]
    	arj: 3.10.22_4 [pfSense]
    
    The process will require 75 MiB more space.
    [1/14] Installing unzoo-4.4_2...
    [1/14] Extracting unzoo-4.4_2: .. done
    [2/14] Installing arc-5.21p...
    [2/14] Extracting arc-5.21p: ...... done
    [3/14] Installing lha-1.14i_6...
    [3/14] Extracting lha-1.14i_6: .. done
    [4/14] Installing arj-3.10.22_4...
    [4/14] Extracting arj-3.10.22_4: .......... done
    [5/14] Installing krb5-1.13.2_3...
    [5/14] Extracting krb5-1.13.2_3: .......... done
    [6/14] Installing cyrus-sasl-2.1.26_12...
    *** Updated user `cyrus'.
    [6/14] Extracting cyrus-sasl-2.1.26_12: .......... done
    [7/14] Installing perl5-5.20.3_8...
    [7/14] Extracting perl5-5.20.3_8: 
    pkg: archive_read_extract(): Can't create '/usr/local/lib/perl5/5.20/AnyDBM_File.pm'
    [7/14] Extracting perl5-5.20.3_8... done
    [7/14] Deleting files for perl5-5.20.3_8: .......... done
    >>> Cleaning up cache... done.
    Success
    

  • Banned

    I have no idea what's the trouble with

    
    /usr/local/lib/perl5/5.20/AnyDBM_File.pm
    
    

    perhaps delete the file if it exists.



  • rm: /usr/local/lib/perl5/5.20/AnyDBM_File.pm: No such file or directory
    


  • it errors on extracting perl … i just tried it at home: works fine for me.

    do you have enough diskspace ? is the harddrive failing ? is the filesystem corrupt ?


  • Banned

    Yeah, sounds to me like you are out of space or something completely unrelated to the package.



  • @heper:

    it errors on extracting perl … i just tried it at home: works fine for me.

    do you have enough diskspace ?

    YES
    is the harddrive failing ?

    NO

    is the filesystem corrupt ?
    i dont know , but pfsense check filesystem always when system boot

    the problem only occour with squid and lightsquid , with lightsquid ocour same error when try delete or update …

    Does anyone would be willing to test the same thing as me?
    install pfsense 2.2.5, install squid and lightsquid, after update to 2.3.



  • ok  guys , problem is in perl5 ..

    i tried install it via console , but not sucess ..

    [2.3-ALPHA][admin@white.corp.com]/root: pkg install perl5
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Checking integrity... done (0 conflicting)
    The following 1 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
            perl5: 5.20.3_8 [pfSense]
    
    The process will require 49 MiB more space.
    
    Proceed with this action? [y/N]: y
    [1/1] Installing perl5-5.20.3_8...
    [1/1] Extracting perl5-5.20.3_8:   1%
    pkg: archive_read_extract(): Can't create '/usr/local/lib/perl5/5.20/AnyDBM_File.pm'
    [1/1] Extracting perl5-5.20.3_8: 100%
    [1/1] Deleting files for perl5-5.20.3_8: 100%
    
    

    ls in /usr/local/lib

    
    [2.3-ALPHA][admin@white.corp.com]/usr/local/lib: ls
    arj                             libldap.a
    c_icap                          libldap.la
    cmake                           libldap.so
    ipsec                           libldap_r-2.4.so.2
    krb5                            libldap_r-2.4.so.2.10.6
    libGeoIP.a                      libldap_r.a
    libGeoIP.so                     libldap_r.la
    libGeoIP.so.1                   libldap_r.so
    libGeoIP.so.1.6.6               libldns.a
    libart_lgpl_2.a                 libldns.so
    libart_lgpl_2.so                libldns.so.1
    libart_lgpl_2.so.2              libldns.so.1.6.17
    libart_lgpl_2.so.2.3.21         libltdl.a
    libart_lgpl_2.so.5              libltdl.la
    libasprintf.a                   libltdl.so
    libasprintf.so                  libltdl.so.7
    libasprintf.so.0                libltdl.so.7.3.1
    libasprintf.so.0.0.0            liblzo2.a
    libcom_err.so                   liblzo2.so
    libcom_err.so.3                 liblzo2.so.2
    libcurl.a                       liblzo2.so.2.0.0
    libcurl.so                      libmcrypt
    libcurl.so.4                    libmcrypt.a
    libcurl.so.4.4.0                libmcrypt.so
    libcurl.so.7                    libmcrypt.so.4
    libdaemon.a                     libmcrypt.so.4.4.8
    libdaemon.la                    libnettle.a
    libdaemon.so                    libnettle.so
    libdaemon.so.0                  libnettle.so.4
    libdaemon.so.0.5.0              libnettle.so.4.7
    libdhcpctl.a                    libomapi.a
    libdst.a                        libonig.a
    libedit.a                       libonig.so
    libedit.so                      libonig.so.1
    libedit.so.0                    libonig.so.1.0.0
    libedit.so.0.0.53               libpcre.a
    libevent-2.0.so.5               libpcre.so
    libevent-2.0.so.5.1.10          libpcre.so.1
    libevent.a                      libpcre.so.1.2.5
    libevent.so                     libpcre.so.3
    libevent_core-2.0.so.5          libpcre16.a
    libevent_core-2.0.so.5.1.10     libpcre16.so
    libevent_core.a                 libpcre16.so.0
    libevent_core.so                libpcre16.so.0.2.5
    libevent_extra-2.0.so.5         libpcre32.a
    libevent_extra-2.0.so.5.1.10    libpcre32.so
    libevent_extra.a                libpcre32.so.0
    libevent_extra.so               libpcre32.so.0.0.5
    libevent_openssl-2.0.so.5       libpcrecpp.a
    libevent_openssl-2.0.so.5.1.10  libpcrecpp.so
    libevent_openssl.a              libpcrecpp.so.0
    libevent_openssl.so             libpcrecpp.so.0.0.1
    libevent_pthreads-2.0.so.5      libpcreposix.a
    libevent_pthreads-2.0.so.5.1.10 libpcreposix.so
    libevent_pthreads.a             libpcreposix.so.0
    libevent_pthreads.so            libpcreposix.so.0.0.3
    libexpat.a                      libpdel.a
    libexpat.so                     libpdel.so
    libexpat.so.1                   libpdel.so.0
    libexpat.so.1.6.0               libpgm-5.2.so.0
    libexpat.so.6                   libpkg.a
    libffi.so.6                     libpkg.so
    libfreetype.a                   libpkg.so.3
    libfreetype.so                  libpkg.so.3.0.0
    libfreetype.so.6                libpng.a
    libfreetype.so.6.12.0           libpng.so
    libgmp.a                        libpng16.a
    libgmp.la                       libpng16.so
    libgmp.so                       libpng16.so.16
    libgmp.so.10                    libpng16.so.16.20.0
    libgmp.so.10.1.3                libpython2.7.so
    libgmpxx.a                      libpython2.7.so.1
    libgmpxx.la                     librrd.a
    libgmpxx.so                     librrd.so
    libgmpxx.so.4                   librrd.so.2
    libgmpxx.so.4.3.3               librrd.so.2.0.15
    libgssapi_krb5.so               librrd_th.a
    libgssapi_krb5.so.2             librrd_th.so
    libgssrpc.so                    librrd_th.so.2
    libgssrpc.so.4                  librrd_th.so.2.0.13
    libhogweed.a                    libsasl2.a
    libhogweed.so                   libsasl2.la
    libhogweed.so.2                 libsasl2.so
    libhogweed.so.2.5               libsasl2.so.3
    libicapapi.so.3                 libsasl2.so.3.0.0
    libidn.a                        libsodium.a
    libidn.so                       libsodium.so
    libidn.so.11                    libsodium.so.13
    libidn.so.11.6.14               libsodium.so.13.2.0
    libidnkit.a                     libsqlite3.a
    libidnkit.so                    libsqlite3.so
    libidnkit.so.1                  libsqlite3.so.0
    libidnkit.so.1.0.2              libsqlite3.so.0.8.6
    libidnkitlite.a                 libssh2.a
    libidnkitlite.so                libssh2.so
    libidnkitlite.so.1              libssh2.so.1
    libidnkitlite.so.1.0.2          libssh2.so.1.0.1
    libidnkitres.a                  libtiff.a
    libidnkitres.so                 libtiff.so
    libidnkitres.so.1               libtiff.so.4
    libidnkitres.so.1.0.1           libtiff.so.5
    libintl.a                       libtiff.so.5.2.2
    libintl.so                      libtiffxx.a
    libintl.so.8                    libtiffxx.so
    libintl.so.8.1.3                libtiffxx.so.5
    libintl.so.8.1.4                libtiffxx.so.5.2.2
    libintl.so.9                    libunbound.a
    libjbig.a                       libunbound.so
    libjbig.so                      libunbound.so.2
    libjbig.so.2                    libunbound.so.2.3.7
    libjbig85.a                     libverto.so
    libjbig85.so                    libverto.so.0
    libjbig85.so.1                  libvstr-1.0.so.0
    libjpeg.a                       libvstr-1.0.so.0.13.2
    libjpeg.so                      libvstr.a
    libjpeg.so.8                    libvstr.so
    libjpeg.so.8.0.2                libxml2.a
    libk5crypto.so                  libxml2.so
    libk5crypto.so.3                libxml2.so.2
    libkadm5clnt.so                 libxml2.so.2.9.3
    libkadm5clnt_mit.so             libzmq.a
    libkadm5clnt_mit.so.9           libzmq.so
    libkadm5srv.so                  libzmq.so.5
    libkadm5srv_mit.so              libzmq.so.5.0.0
    libkadm5srv_mit.so.9            lighttpd
    libkdb5.so                      mysql
    libkdb5.so.8                    openvpn
    libkrad.so                      perl5
    libkrad.so.0                    php
    libkrb5.so                      php-fpm.conf
    libkrb5.so.3                    python2.7
    libkrb5support.so               sasl2
    libkrb5support.so.0             snmp_regex.a
    liblber-2.4.so.2                snmp_regex.so
    liblber-2.4.so.2.10.6           snmp_regex.so.0
    liblber.a                       snmp_regex.so.0.0.0
    liblber.la                      snmp_ucd.so
    liblber.so                      snmp_ucd.so.1
    libldap-2.4.so.2                snort_dynamicrules
    libldap-2.4.so.2.10.6           xml2Conf.sh
    
    [2.3-ALPHA][admin@white.corp.com]/usr/local/lib: cd perl5
    perl5: No such file or directory.
    
    

    i delete perl5 folder and install perl5 , after i try for reinstall squid and give me this error .

    >>> Installing pfSense-pkg-squid... 
    Checking integrity... done (0 conflicting)
    The following 12 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	pfSense-pkg-squid: 0.4.7 [pfSense]
    	squid_radius_auth: 1.10 [pfSense]
    	squid: 3.5.9_1 [pfSense]
    	krb5: 1.13.2_3 [pfSense]
    	cyrus-sasl: 2.1.26_12 [pfSense]
    	squidclamav: 6.13 [pfSense]
    	c-icap: 0.3.5_2,2 [pfSense]
    	c-icap-modules: 0.3.2_4 [pfSense]
    	clamav: 0.98.7 [pfSense]
    	unzoo: 4.4_2 [pfSense]
    	arc: 5.21p [pfSense]
    	lha: 1.14i_6 [pfSense]
    
    The process will require 26 MiB more space.
    [1/12] Installing unzoo-4.4_2...
    [1/12] Extracting unzoo-4.4_2: .. done
    [2/12] Installing arc-5.21p...
    [2/12] Extracting arc-5.21p: ...... done
    [3/12] Installing lha-1.14i_6...
    [3/12] Extracting lha-1.14i_6: .. done
    [4/12] Installing krb5-1.13.2_3...
    [4/12] Extracting krb5-1.13.2_3: .......... done
    [5/12] Installing cyrus-sasl-2.1.26_12...
    *** Updated user `cyrus'.
    [5/12] Extracting cyrus-sasl-2.1.26_12: .......... done
    [6/12] Installing c-icap-0.3.5_2,2...
    ===> Creating users and/or groups.
    Using existing group 'c_icap'.
    Using existing user 'c_icap'.
    [6/12] Extracting c-icap-0.3.5_2,2: .
    pkg: archive_read_extract(): Can't create '/usr/local/etc/c-icap/c-icap.conf.sample'
    [6/12] Extracting c-icap-0.3.5_2,2... done
    [6/12] Deleting files for c-icap-0.3.5_2,2: .......... done
    >>> Cleaning up cache... done.
    Success
    

    I think the upgrade process, something in the permissions given a problem



  • pkg: archive_read_extract(): Can't create '/usr/local/share/c_icap/templates/squidclamav/en/MALWARE_FOUND'
    

    ls -l in /usr/local/share show me this

    lrwxr-xr-x    1 root  wheel    39 Dec 10 21:41 c_icap -> /usr/pbi/squid-amd64/local/share/c_icap
    
    

    maybe it a problem with symlinks ?



  • after delet alls folder with ""pkg: archive_read_extract(): Can't create""

    squid install and give this in logs

    	Cannot open '/var/squid/logs/access.log' for writing. The parent directory must be writeable by the user 'squid', which is the cache_effective_user set in squid.conf.
    

    Do you believe it may be something in pfsense update process 2.2 to 2.3, something related to squid and squid light, or should I just stop and investigate bother you guys?



  • Dont stop investigating.

    When you figure it out it'll be easier to fix.
    Ideally you should be able to replicate it consistently.

    Thanks.


  • Banned

    @whitexp:

    Do you believe it may be something in pfsense update process 2.2 to 2.3, something related to squid and squid light, or should I just stop and investigate bother you guys?

    There is no usable upgrade. Wipe whatever stale junk you have there. And yes, that includes entire /var/squid/. I'd frankly recommend reinstalling the entire box from scratch and restoring the config backup to get rid of any leftovers after loads of PBI hacks.


Log in to reply