Proxy transparente + multiwan (fail over)



  • Buenas tardes

    Su apoyo para este problema que aun no puedo resolver…

    Tengo una versión de pfsense 2.2.4-RELEASE, he configurado el pfsense con 2 proveedores de servicio de internet, el número uno con una ip publica 187.200.167.2 con gateway 187.200.167.1 por ejemplo , y otro proveedor que proporciona DHCP, he configurado el pfsense tal que cuando uno de los servicios se encuentre fuera, se redirecciones el trafico con el otro proveedor, esta configuración lo determina si el pfsense detecta paquetes perdidos, hasta este punto he logrado que funcione pero también requiero de un proxy que bloquee 80 y 443, también lo he configurado pero mi problema empieza en el firewall, ya que no logro integrar estos dos servicios ya que cuando pierdo a un proveedor de internet, no logro navegar a internet hasta que ingrese al equipo y ponga al gateway que esta en línea como predeterminado.

    He llegado a la conclusión que mi falla esta en el firewall, ya que no logro pasar mi trafico por el gateway que esta activo.

    Espero me puedan apoyar con este problema.
    ![rules firewall.JPG](/public/imported_attachments/1/rules firewall.JPG)
    ![rules firewall.JPG_thumb](/public/imported_attachments/1/rules firewall.JPG_thumb)



  • Cuando dices falla, te refieres a que el proxy deja de operar o sea pierdes acceso a Interent hasta que llegas y cambias el gw?



  • Es correcto, me quedo sin salida a internet, para volver a tener servicio cambio el gateway o vuelvo a activar nuevamente mi interfaz el cual esta definida como predeterminada.








  • Tengo entendido que squid no fue hecho pensando en multi-wan's.
    Si alguien lo tiene operando que saquen, saludos.



  • Aunque lo he intentado la verdad es que nunca ha funcionado.

    Lo mejor es colocar un balanceador antes.



  • Hola:
    Yo tengo trabajando sin problemas un pfsense 2.2.4 con multiwan, balanceo, squid+squidguard y reglas en el firewall para que no se conecten a algunos sitios. Creo que tu problema es que no está bien hecho el balanceo. No es problema de squid.
    Mejor que  explicar como lo tengo yo hecho, te paso el enlace del vídeo donde lo explican paso a paso. Yo lo hice así y me funciona el balanceo. Pruébalo y si no va bien, lo comparamos y vemos el fallo.
    Un saludo
    Youtube Video



  • Hola

    De ante  mano gracias a todos por su ayuda

    He probado con las configuraciones y realmente si hace el redireccionameinto de trafico hacia la WAN activa, sin embargo he configurado un proxy transparente con el squid3 y el squidguard con certificado ssl para restringir páginas https el cual en las reglas del firewall envío el trafico al puerto 8081, pero por alguna razón cuando desconecto un proveedor de servicio y se activa la otra, mi certificado lo rechaza pero el ping y el tracert responden, no se sí el detalle es en el firewall donde envío el trafico hacia el puerto o es el proxy. Por otro lado cuando estan los dos servicios activos el certificado me responde de manera correcta permitiendo restringir páginas 80 y 443.

    Gracias por su apoyo, quedando en espera de sus comentarios.

    ![firewall rules.JPG](/public/imported_attachments/1/firewall rules.JPG)
    ![firewall rules.JPG_thumb](/public/imported_attachments/1/firewall rules.JPG_thumb)



  • Me parece que el video solo muestra como realizar un balanceo y no muestra nada en relacion al proxy.

    Por otro lado las conexiones que se generan desde el mismo firewall no se "balancean" unicamente salen por la wan que esta operando por "default" asi que es incorrecto asegurar que el squid esta siendo balanceado.

    ojala alguien pueda aportar mayor info.

    saludos


Log in to reply