[Solved] Can connect from LAN but not from outside



  • I have done a fresh install with 2.2.5 and I could connect just fine to my VPN but when I set up pfsense as client to a commercial VPN I can't connect to my own VPN anymore, unless I connect from inside network.
    The OpenVPN app in my pad just says "waiting for server". I'm connecting to my real IP address, not the VPN IP address of the commercial provider. The logs in the OpenVPN tab are empty.

    This used to work before I did a new install. I could connect from anywhere and access TFTP in pfsense and also access internet through the commercial VPN that was setup in pfsense.

    The interface "MinVPN3" is my VPN.
    The interface "OVPN" is the commercial provider.

    I will provide screenshots here of my rules and NAT. Tell me if more information is needed.









  • Try to check "Don't pull routes" in pfSense client settings.



  • @viragomann:

    Try to check "Don't pull routes" in pfSense client settings.

    I checked that and saved. Rebooted just in case but I still couldn't connect.

    However I see in advanced configuration in client it says "pull;" .



  • You may also check your routing table (Diagnostic > Routes) when client connection is up.
    I think, you will get a default route for the VPN. So pfSense sends any responses to VPN instead of WAN.

    Since you've set up policy based routing with firewall rules, there is no need for pull routes from VPN provider, I think. So you may also remove the "pull" option.


  • LAYER 8 Netgate

    You are natting your OpenVPN port to your Wii.



  • @Derelict:

    You are natting your OpenVPN port to your Wii.

    Yes I was! Everything works after I disabled the Wii rules.

    Thank you for the help!


Log in to reply