Squid blocks (Astril) VPN users



  • I'm running pfSense 2.2.4 with Squid 3.4.10.

    With the pfSense community's help I'm very excited to get Squid running but my users are reporting that Squid is blocking their VPN. One popular VPN my users use is Astril and they would get this reply:

    Date: Thu, 17 Dec 2015 00:40:52 GMT
    Server: gwiseguy/2.0
    Location: http://www.youtube.com/
    Content-Length: 0
    Content-Type: text/html
    X-Xss-Protection: 1; mode=block
    Proxy-Connection: close

    My users use VPN because we're in a country where Google/Youtube etc are blocked by the government. >_<

    Squid is in transparent mode (proxy only http, not proxying https MITM, no special rules).

    I wasn't able to find anything in this forum or on Google.

    I hope this is my last hurdle to deploy pfSense and Squid. Thank you guys again in advance!!!


  • Banned

    Squid does not block any such thing. Youtube redirects to HTTPS.



  • Squid seems to be blocking something. Is it true that Squid blocks by default, if so, is there a way to make Squid allow everything by default?

    For example, put a "http_access allow all" in the "Custom ACLS (After Auth)" setting?

    Thank you doktornotor, much appreciated!



  • Squid seems to be blocking something. Is it true that Squid blocks by default

    Squid is a web cache.  It doesn't block anything by default.  Transparent mode doesn't work with HTTPS unless you have installed a trusted certificate on every client computer that will use the proxy.


Log in to reply