XBOX 360 streaming problem



  • I'm not sure if this should be posted in gaming since it has nothing to do with gaming other than it uses the gaming console.  My problem is getting my XBOX 360 to recognize my PC.  I used a combination of the instructions here:

    http://www.jakeludington.com/xbox/20060321_easy_divx_to_xbox_360_streaming.html
    http://www.digital-digest.com/articles/Xbox_360_DivX_XviD_Playback_Guide_page1.html

    My goal is to get it work with WMP 11 only - no TVersity.  I'm wondering if anyone has gotten their XBOX 360 to see their PC using these methods.  I'm running pfSense 1.2 final.

    My first problem was WMP didn't show the XBOX 360 as a device.  I found out later from one of the guides that I needed to add the XBOX 360 as an allowed device before I could even see it under the library.  I double checked the services needed to be turned on and even restarted it.  I have uPnP turned on from the LAN interface which the XBOX 360 is connected directly through a Cisco 2950 switch to the LAN interface.

    If you look at the uPnP status page, you can see that XBOX is registered with an IP address using UDP protocol on port 3074.

    This leads to a second question now, I have to test my connection every time I turn on the XBOX 360 if you want to get on XBOX Live or if I want to try and connect to a PC.  I'm not certain if this is standard for the XBOX 360 or if there can possibly be a misconfiguration of my Cisco router.  I noticed that it takes a while to get a DHCP lease when hooking up a PC and sometime times out.



  • Well since I didn't get any input, I bit the bullet.  I ended up using TVersity and it worked without a hitch.  So either I'm configuring WMP 11 wrong or it doesn't like something with pfSense unless someone can confirm they have it working with WMP 11 under pfSense.



  • Seems like you have quite a problem. Sad to see you don't have any replies, as I have a topic here waiting on a reply as well  :-\

    I've been using pfsense for a week or so now and streaming from WMP11 to both my PS3 and 360 works flawlessly. I'm a huge noob when it comes to pfsense, so I can't really help you out too much with it.

    After a quick google, I found this: http://www.tomshardware.com/forum/23961-42-problem-connecting-xbox-computer-switch. Apparently you're going to have to use a router and not a switch. Doesn't make a lot of sense to me, being a pfsense noob, but it seems like your PC and 360 should be on the same LAN…but maybe not.



  • Ya they ended up on the right track there…but you can use a switch....in this case here he had a 2950...He could have had anything setup on that switch, even without him knowing.  who knows, whoever had the switch may have had 2 different Vlans or even some ACL's (access control lists, basically a manual firewall for a switch of that type) on it...It could have been several different issues.  I didn't see this post earlier, I probably could have helped.  Nonetheless it should have worked, my bet was a configuration error on the cisco switch.  That's an enterprise class switch and not some soho linksys or dlink type.  It has much more things you can configure than a home or office router/switch.


Log in to reply