Cannot install Dansguardian



  • Hello!

    I am trying to install DansGuardian, but I was not too lucky at it.

    Here is the output:

    _Beginning package installation for Dansguardian .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading Dansguardian and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/dansguardian-2.12.0.3_2-i386.pbi ...  (extracting)
    Verifying Checksum...SKIP_ARCHLINES: 62
    Archive checksum: 875d99df032b9cb53bb5060382e8bb96fba5469e23a7552016a96263e6ace312
    Saved checksum: 264fb983f122205400d8362e7b1784b5db79b47dfbf9fe20d32c880d2ac2c803
    ERROR: /root/tmp/apkg_dansguardian-2.12.0.3_2-i386.pbi failed checksum, the archive may be corrupt.
    of dansguardian-2.12.0.3_2-i386 failed!

    Installation aborted.Removing package...
    Starting package deletion for dansguardian-2.12.0.3_2-i386...done.
    Removing Dansguardian components...
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted._

    Obviously, there is a problem with the download, as the checksum is totally different.
    I tried to download the file from the repository from my laptop (which is connected to the internet through the watchguard pfsense), and it was downloaded properly, with matching checksums.

    Now… What would be the reason for it not properly downloading? How should I proceed to investigate further?
    Can't I manually install it from the copy that I've downloaded to my laptop?

    I am running the 2.2.6 version nanoBSD on 1gb.
    As for the hardware>
    1.2 Ghz Celeron Tualatin
    256 Mb RAM

    later edit:

    I thought maybe the tmp was full, as it has just 49mb assigned to it, so I connected to the box as root via ssh and removed some unused downloads from the tmp directory. Tried it again afterwards, but with the exact same output :(

    Pls take into account that I am kind of a newbie (or nooby) in regards of pfsense, and also linux in general :(



  • C'mon guys, gimmie a hint here :(


Log in to reply