[solved] System Logs Firewall | Manage Firewall Log



  • Hi,

    At the section Manage firewall log on Systems Logs / Firewall , when I uncheck the option "Log packets matched from the default block rules in the ruleset" and try to save, the error shows up:

    Fatal error: Cannot unset string offsets in /usr/local/www/status_logs_filter.php on line 216 Call Stack: 0.0001 236992 1. {main}() /usr/local/www/status_logs_filter.php:0 PHP ERROR: Type: 1, File: /usr/local/www/status_logs_filter.php, Line: 216, Message: Cannot unset string offsets

    At
    2.3-ALPHA (amd64)
    built on Sun Jan 03 04:28:58 CST 2016
    FreeBSD 10.2-STABLE

    Regards,
    JC Bilhega



  • can not reproduce on a slightly older build.

    nothing has been changed on that file in the last 13 days … have you set any other specific settings ?



  • I can't make that happen, and I don't see how the code and XML data can get in a state where that happens - it is trying to unset() some stuff in $config['syslog']

    What is in your config.xml <syslog>section?</syslog>



  • @phil.davis:

    What is in your config.xml <syslog>section?</syslog>

    It is empty:

    -> If I go on "System logs / Settings" and just do a save with the defaults values, the section of <syslog>is filled up with some informations and the error not ocorrurs anymore.

    My config.xml was exported (backup) from a 2.2.6 box and restored on this 2.3, and there (2.2.6) the syslog section is empty also.</syslog>



  • Was this a fresh install, not upgrade, and no config restore?



  • Yes, I confirmed it is a problem when you have a factory default config and have never set any general system log settings yet.

    Redmine https://redmine.pfsense.org/issues/5731
    Github fix PR https://github.com/pfsense/pfsense/pull/2350



  • Thanks Phil.  Appreciate the fix.



  • Thanks.


Log in to reply