OpenVPN Client Traffic



  • Hallo zusammen,

    ich habe das Problem das ich den Client Traffic nicht durch den PFSense OpenVPN an z.b. den VPN Anbieter geleitet bekomme.

    Die Clients haben sobald der VPN aufgebaut ist kein Internet mehr. Sobald die VPN Verbindung getrennt ist, geht wieder alles.

    Woran kann es liegen ?

    Ziel ist es eine Standort Verbindung mit einem VPN Anbieter aufzubauen, so das der komplette Traffic von allen Rechnern im Heimnetz über den VPN Tunnel ins Internet geht.

    Über Hilfe wäre ich sehr dankbar.

    Mit freundlichen Grüßen

    Rafael Seeck



  • Was hast du denn bereits gemacht, außer den OpenVPN Client eingerichtet?

    Interface dafür erstellt?
    FW Regel für das LAN mit Gateway OpenVPN erstellt?
    Ausgehendes NAT auf dem VPN Interface aktiviert?



  • Ich habe bisher nur die Client Verbindung aufgebaut.

    Interfaces habe ich 2 Stück 1x WAN und 1x LAN.

    Die VPN Verbindung wird auch aufgebaut und gehalten aber es geht absolut kein Traffic durch.

    Was kann ich senden was weiter hilft?!



  • Wenn die Verbindung aufgebaut wird ist das ja schon mal soweit i.O.
    Aber du musst eben noch einstellen dass sie auch genutzt wird.

    Dazu erstellt du zunächst ein VPN Interface (Interfaces - assign - ovpnc(x)), bennenst es entsprechend und aktivierst es.

    Jetzt solltest du auch ein neues Gateway für die Verbindung haben (unter System - Routing).

    Als nächstes stellst du in den gewünschten Firewallregeln dieses Gateway ein.
    Also z.B. deine LAN allow any Regel bearbeiten und dort unter Gateway das VPN-Gateway angeben.
    (Achtung: wenn du auch intern über mehrere Interfaces routest brauchst du jetzt davor eine Regel für die entsprechenden Netze)

    Als letztes noch NAT kontrollieren: unter Outbound für dein VPN interface NAT für Source: "dein LAN" aktivieren.

    Nun sollte dein Traffic über den VPN laufen.


Log in to reply