OpenVPN + MultiWAN = 0?



  • Trying to set up a brand new pfSense box with both load balancing and OpenVPN support.  However, we have had problems, so we tried to start over and see where the problem lies.

    We did a fresh install with WAN and LAN and configured OpenVPN.  Everything worked. Test machine could ping and gain access to a client computer from outside the network.  As soon as the OPT interface is enabled, however, OpenVPN stops working.

    Is this a know issue? Does OpenVPN work or not in a multiple WAN environment?  If so, how does one create rules and configurations to allow this.  We have spent extensive time on the forums but have not, as yet, seen a solution to this particular configuration.

    Details of our system are:
    WAN is a T-1 Static IP address
    OPT is a DSL Static IP Address
    LAN is a non routable IP address (i.e. similar to 10.0.0.1)

    pfSense is running on a P3 1GHz machine with 1GB RAM and 3 NIC cards (one for each network– WAN, OPT, and LAN)
    We are currently running pfSense 1.2  (Built Sunday Feb 24, 2008).

    Any suggestions would be greatly appreciated. Thanks.

    You may also contact us at nnwail .at. yahoo.com



  • Can you post the output of the openVPN log?
    I think i've read somewhere something about OpenVPN only working with TCP with multiple WAN's.


Log in to reply