Openconnect client on pfsense 2.2


  • Hi everyone,

    I tried hard to find the answer by myself on this one but couldn't succeed.

    I whant to be able to connect my pfsense router to my company's Cisco vpn and beeing able to reach the servers from my local computers.

    What I did and is working:
    from sh connection to my pfsense,
    I activated and updated pkg by doing "pkg" & "pkg update"
    then, I installed openconnect with "pkg install openconnect"
    I did a rehash on my console and tried to connect using the openconnect manual and it succeeded

    From this point, I was able to ping any of my company's server from my pfsense.

    Now the bad things…
    I don't see my interface "tun0" anywhere in the webui
    I do see the route from the command "netstat -rn" but none of my local computer are able to ping my company's IP
    I think the problem could be solved by adding a nat between my lan interface and the tun0 interface
    But if I can't get my tun0 interface to appears on my webui, I can't create, nat,rules,route or anything

    as some ppl already suggested, I tried to remove "tun" from the vfaces array in the util.inc file but didn't change anything.

    can anyone help fix this issue please?