Traffic graph widget scale type not changing with gui toggle



  • Probably they are going to change the traffic graph widget for 2.3 anyway but there is this problem with the current one.

    As of at least the build from 1/13 and still today the traffic graph widget shows scale type set to up and toggling the radio button to follow (and saving) has no effect on either the graph or the config:

    pre gui change:

    pfSense shell: print_r($config["widgets"]["trafficgraphs"]);
    pfSense shell: exec
    Array
    (
        [shown] => Array
            (
                [item] => Array
                    (
                        [0] => wan
                        [1] => lan
                        [2] => opt1
                    )
    
            )
    
        [refreshinterval] => 10
        [scale_type] => up
    )
    

    post gui change:

    pfSense shell: print_r($config["widgets"]["trafficgraphs"]);
    pfSense shell: exec
    Array
    (
        [shown] => Array
            (
                [item] => Array
                    (
                        [0] => wan
                        [1] => lan
                        [2] => opt1
                    )
    
            )
    
        [refreshinterval] => 10
        [scale_type] => up
    )
    

    After looking at the form code in /usr/local/www/widgets/widgets/traffic_graphs.widget.php file I noticed that both lines 179 and 183 have the same value so clicking either button results in the same thing:

    line 179:

    input name="scale_type" type="radio" id="scale_type_up" value="up"  />
    

    line 183:

     />
    

  • Developer Netgate

    Just pushed a fix.

    Thanks.


Log in to reply