How to configure WLAN to receive signal from protected wireless network?



  • Hi folks :), I am looking for an expert advice  ::) on how to configure my WLAN to receive signal from protected wireless network  :'(.

    I have successfully installed and configured pfSense 2.2.6 (i386) on my old laptop (Intel Duo Core 1.73 GHz 797 MHz Laptop, Ethernet, Ra-link - Wireless; 1Gb Ram; 80 Gb Hard disk) and wondering  ::) how to configure my WLAN (Ra-Link 802.11 bg WLAN, class 0/0, rev 2.00/0.01) to receive internet signal from the wireless connection provided by my landlord.

    Thanks in advance!!

    Regards



  • Assign the RALink wireless adapter to an pfSense WAN interface and enable the interface as DHCP client. Then assign ethernet adapter to LAN. Then setup wifi via WAN interface settings. Set wireless to IBSS and set SSID to the one your are connecting to, along with the WPA key if used. Attach client or router to laptop ethernet as LAN.

    There are issues with some RaLink adapters. You should find out the minuite you enable the interface and save. It will crash there. Some not all. Seems pfSense 2.3 beta did better for me.



  • Phishfry, thanks for the message :).

    As per your instruction, I have assigned the RALink wireless adapter to an pfSense WAN interface and enabled the interface as DHCP client. I have also assigned the ethernet adapter to LAN.  8)

    :-[ Could you please elaborate the further setup of wifi via WAN interface, setup of wireless to IBSS and SSID?  :'( It would be really easy if you could provide the pic of setup page.

    Thanks  :)



  • pfSense defaults to IBSS so all you really need to do is enable the interface and set SSID and wpa key.

    I am not near any pfSense wireless right now but this screen is what you need to find:

    Ignore the article -it is for Access Point mode not client mode-IBSS. Look at "More Wifi Settings" near the bottom. This is just an example of wifi setup screen that should be under your WAN interface. Just set your SSID and Key and save. Ignore the bridge stuff.
    https://www.artooro.com/2015/02/20/how-to-configure-wi-fi-in-pfsense/



  • OK had a chance to check this. You want-

    Mode: Infrastructure BSS
    SSID: To Access Point you are connecting to.
    WPA: Set WPA/2 Keys if used.



  • I just tested this with a USB RALInk fob and it works. You can just enable the interface and save and it sets it self to Infrastructure Mode by default. You can then go to the Status Tab and pick Wireless and see a list of active Access Points you can connect to..

    I did not see any crash on 2.2.6 like I did earlier with this RT3070 Fob on older versions.



  • Phishfry, thanks for the help  :)

    As per your instruction, I have successfully setup the WAN interface and now to receive wifi signals from the secured wireless network and access the internet through ethernet . It would have been impossible without your help.

    However, while connecting through the pfsense router. :-\ I'm getting error "scan_task: oops! scan cancelled during driver call(2)!" on my pfsense screen.

    Thanks in advance :)


Log in to reply