Squid Reinstall Fails



  • The PBI fixe allowed other packages to reinstall and run however squid and squid guard still fail.

    [10/13] Extracting squid-3.5.12: …......
    pkg: cannot rename //usr/local/etc/squid/errors/zh-cn.V4allnlIgcpQ to //usr/local/etc/squid/errors/zh-cn: Is a directory
    [10/13] Extracting squid-3.5.12… done
    [10/13] Deleting files for squid-3.5.12: …....... done

    Cleaning up cache... done.
    Success

    I ssh and this path doesn't even exist. Package can't be installed or removed. Both fail.

    Similar error for squid guard..

    [3/5] Extracting squid-3.5.12: …......
    pkg: cannot rename //usr/local/etc/squid/errors/zh-cn.LgMBhdCsrdQc to //usr/local/etc/squid/errors/zh-cn: Is a directory
    [3/5] Extracting squid-3.5.12… done
    [3/5] Deleting files for squid-3.5.12: …....... done

    Cleaning up cache... done.
    Success



  • 32 or 64 bit? Full or nano?

    Not seeing that, though have only tried 64 bit full installs.



  • Apu4 with SSD. Upgrade from 2.2.6 wanna say 64 full.



  • Clicked on squid from services menu and saw this:

    Warning: dir(/usr/pbi/squid-amd64/etc/squid/errors/): failed to open dir: No such file or directory in /etc/inc/pfsense-utils.inc on line 514 Call Stack: 0.0248 234616 1. {main}() /usr/local/www/pkg_edit.php:0 0.2241 4287560 2. eval('squid_before_form_general($pkg);') /usr/local/www/pkg_edit.php:141 0.2243 4290160 3. squid_before_form_general() /usr/local/www/pkg_edit.php(141) : eval()'d code:1 0.2243 4290328 4. get_dir() /usr/local/pkg/squid.inc:284 0.2243 4290512 5. dir() /etc/inc/pfsense-utils.inc:514 Fatal error: Call to a member function read() on boolean in /etc/inc/pfsense-utils.inc on line 515 Call Stack: 0.0248 234616 1. {main}() /usr/local/www/pkg_edit.php:0 0.2241 4287560 2. eval('squid_before_form_general($pkg);') /usr/local/www/pkg_edit.php:141 0.2243 4290160 3. squid_before_form_general() /usr/local/www/pkg_edit.php(141) : eval()'d code:1 0.2243 4290328 4. get_dir() /usr/local/pkg/squid.inc:284 PHP ERROR: Type: 1, File: /etc/inc/pfsense-utils.inc, Line: 515, Message: Call to a member function read() on boolean


  • Rebel Alliance Developer Netgate

    You probably still have some symlinks on your drive from the old install that haven't been removed, try the command from the other thread again. If it still isn't resolved, at that point you are better off to backup the config and reinstall 2.3 then restore your configuration.



  • I was able to make it work from ssh by rmdir and the two left over directories in the error folder. Now it appears to be running but ever site produces a white page with no content. I see a no data received as well.


Log in to reply