Creating Hyper-V VM to be exported on Azure

  • Hi guys,
    I am actively using Azure for my whole infrastructure but since Azure Gateway is crap I am looking forward to host a VM in Azure with pfSense on it which is really great.
    Here is the point where I am:
    1. I need to deploy an Azure VM in the new Resource Manager System (not a classic one)
    2. I have Windows 10 with Hyper-V installed which is where I create the vhd to create the VM for Azure
    3. I used as baseline this guide

    I explain you the problems I am having.
    I am able to get in Hyper-V a VM running which is reachable in SSH and via http for the pfsense configuration. The machine is created with a vhd fixed size of 1gb and two Network Interfaces (legacy network interfaces are not working for me)
    When I upload the vhd to Azure creating the correct VM though it is no way to connect to the VM any more. I tried SSH and http but the machine seems to not exist.

    Can you help me on this issue?
    Am I creationg the VM wrong in Hyper-V?
    Am I missing something to configure on the pfsese in order to be Azure ready (I installet phthon and the Azure Agent on the pfsesne machine) ?
    Do you know of any topic or forum where someone tried something like that?

    Thanks a lot for the help :)

  • I am stuck at the very same point as you.

    Azure support suggested i follow this article too

    I did the additional steps defined in this document namely the echo commands and i am now in the process of uploading my vhd.

    I will report back my progress.

    Please let me know if you have any luck also


  • Have you tried to connect to the pfSense VM from another Azure VM which is on the same subnet as pfSense's LAN interface ?

  • I tried that guide too.
    I see that the waagent is not running by deafult and I also enforced the launch with a script at boot.
    But no way to connect to the machine once uploaded.
    I als tried to connect from a nother vm within the same network, but with no success.
    If needed I can share the link to the vhd I created if someone wants to review it:

  • Insalata_fresca

    Thank you for posting your VHD. Very helpful. Atleast it boots for in azure. There just seems to be a problem with the NICs.

    Here is the boot diagnostics from running YOUR vhd.

    A few questions;

    • Did you assign hn0 as WAN NIC?

    • Did you assign hn1 as LAN NIC?

    • Did you Enable networking Configure the hn0 interface so Azure can use /etc/rc.d/netif to stop and start networking:
      root@:~# echo 'ifconfig_hn0="SYNCDHCP"' >> /etc/rc.conf
      root@:~# service netif restart

    • Enable SSH Enable the SSH daemon in /etc/rc.conf:
      root@:~# echo 'sshd_enable="YES"' >> /etc/rc.conf
      root@:~# service sshd restart

    What Static IP Address did you assign to hn1? (Your LAN NIC) - It appears from the boot diagnostics capture that perhaps you set it to ?
    The article uses

    We are soo close now I think. I wish I could get as far as you and have a booting VM!

    How exactly are you enabling the Azure waalinux agent? Can you please share the command. I am a complete noob.

    Are there any other steps you are doing whilst preparing the Hyper-V machine before upload?

    Happy to skype/email if you want to work at this issue together. As for timezones I am in Sydney Australia but can generally make myself available for chat at anytime.

    Thanks in Advance.

  • So an Update.

    Insalata_fresca… you did set the LAN nic to "" once I configured my vnets accordingly I could communicate to it from another VM on the SAME subnet. SSH directly the LAN interface

    I am now about to attempt the User Defined Routes and IP Forwarding for the vnet. I will report my progress.

    If I can do anything to assist you please let me know, if I can suggest turning on boot diagnostics from the azure preview portal, and then checking for the screenshot. that was the biggest help in diagnosing the issue with your image.

    Thank you again soo much for your working VHD!!!!

  • I’ve uploaded the image that I used for my blog post to OneDrive and you can find it here:

    Details about this image

    Username: admin
    Password: pfsense
    WAN Interface: hn0 (DHCP)
    LAN Interface: hn1 (
    Blog Post URL:

  • Hi Anglover,
    I need some information from you.

    I was not able to run your commands. Opening the vhd in Hyper-v
    service sshd restart
    service netif restart
    are not existing in my vhd.

    1. How have you read the logging in your screenshot? where you in a hyper V?
    2. What VM have you created, a classic or a RM Azure Virtual Machine?
    3. Can you share me your vhd and how you deployed the machien please?

    Thank you


  • @vkappas

    Can you share an working image of pfsense that can be uploaded to Azure, i have been trying to do this for quite some time.
    I was able to upload and get it started, im stuck with HTTP referer error.

Log in to reply