WPAD issues with 443? (SOLVED)



  • Hi,
    So far everything is working flawless with WPAD but I was wondering if theres another way without me blocking on the LAN ports 80 and 443.

    The issue with that ex: I have godaddy email exchange service and somehow it uses port 443 so it wont connect no matter what and by also blocking port 80 bitdefender cannot download the updates.

    At first i had transparent proxy disabled but then I enabled  it and disable port 80 on the LAN firewall the bitdefender can now download the updates.  Ofcourse this is just a workaround and not a good way because if i wanted to put limiter there's issues with transparent proxy

    So i thought would it be possible somehow to force all apps, to use the WPAD in way like transparent proxy? I was looking at other posts and someone did accomplish this with NAT not sure how.

    Thank you

    EDIT: In my case because im the only one using exchange from godaddy i just added a rule to ignore the WPAD the rest uses POP3 and transparent proxy for the clients that cannot auto detect proxy on port 80, Prob not the best solution but it works



  • I would think you could make a firewall rule that falls before the block all rule for those ports to allow specific machines through should you have a machine that requires port 80 or 443 for communications, such as your email exchange service.  As far as individual programs that need such access, you should be able to change bitdefenders settings to use the proxy manually (yeah, I know, a pain), but according to BitDefender, it should import the settings from IE…  http://www.bitdefender.com/support/how-do-i-configure-bitdefender-2015-to-use-a-proxy-internet-connection-1282.html

    As for forcing programs to use wpad... If they don't support it, they just don't support it, not much you can do about that.

    I suggest asking at the bitdefender forum if you have issues with how their software works in terms of updates... http://forum.bitdefender.com/index.php?act=idx



  • Hi,
    Thank you for the reply,

    Well..lets say I give that user access to 443 yes the Emails will come though but now he can navigate to https sites with no issue.

    I was wondering if theres a way to force everything using NAT to redirect to squid ports

    So after that all the programs would have to use port 3128

    That being said bitdefender uses port 80 it works when i have transparent proxy and Yes if it comes to that I have gravity point and could just do it on the console with the proxy updates.

    But I just dont like the fact blocking port 80/443 seems pretty radical


Log in to reply