OpenVPN AUTH_FAILED error



  • This has been happening for months and I have just been dealing with the problem ever since I first set up OpenVPN following this guide, https://www.highlnk.com/2013/12/configuring-openvpn-on-pfsense/

    Essentially, I connect to my VPN server using an .ovpn file exported from the pfsense webgui (following that guide I linked above) and I use the command sudo openvpn ~/.vpn/myconfig.ovpnto connect to the VPN. When I do this, all works well. However, after a certain amount of time (I think) or just for some odd reason the connection ALWAYS times out with an error showing on my terminal saying```
    Sat Jan 23 14:20:46 2016 AUTH: Received control message: AUTH_FAILED
    Sat Jan 23 14:20:46 2016 SIGTERM[soft,auth-failure] received, process exiting

    
    I shall provide with my .ovpn file as maybe that may give some clues?
    
    

    dev tun
    persist-tun
    persist-key
    cipher AES-256-CBC
    auth SHA1
    tls-client
    client
    remote INSERTIPHERE 1194 udp
    lport 0
    verify-x509-name "INSERTNAMEHERE" name
    auth-user-pass
    auth-nocache
    ns-cert-type server
    comp-lzo adaptive

    <ca></ca>

    <tls-auth>#

    2048 bit OpenVPN static key

    #</tls-auth>
    key-direction 1

    (I censored the characters in the ca, cert, key, and tls-auth obviously, as well as the device's name and external IP). 
    
    Now as for the pfsense server, I have enabled SSH access and would provide you with an /var/log/openvpn.log file ….but for some odd reason the logs that are in there are only from September.
    
    Do you guys have any clue as to why it is doing this? Could it be my ISP constantly booting me off/resetting connection (As a note I do not use their DNS servers, I use the DNS servers provided from OpenNIC)? If it is not my ISP why in the world is this happening?


  • Hi altiris,

    I had the same problem. The key-direction 1 in the .ovpn file should be before the <tls-auth>section and not after. I think it is a bug in the auto-generated file.

    key-direction 1
    <tls-auth>#

    2048 bit OpenVPN static key

    –---BEGIN OpenVPN Static key V1-----
    ...</tls-auth></tls-auth>