2.3 beta 26th Jan - powerd mode config doesn't appear to work



  • hi,

    i've been testing the beta's for a few days now hoping to cure a locking issue with realtek lan (not ideal i know). So far the problem i was experiencing on 2.2.6 has gone. But i've come accross an issue in the webconfig.

    enabling powerd in system > advanced > Miscellaneous works, but it doesn't appear changing the default hiadaptive to any of the other settings works.

    I've tried saving and rebooting but checking the configuration again and it is still set on hiadaptive mode. I can't be certain but the cpu load avaerages suggest the setting isn't working.

    The log doesn't show anything specific that i can see (although i'm very new to pfsense and freebsd).
    Jan 26 19:08:36 xinetd 18014 Starting reconfiguration
    Jan 26 19:08:36 xinetd 18014 Swapping defaults
    Jan 26 19:08:36 xinetd 18014 readjusting service 6969-udp
    Jan 26 19:08:36 xinetd 18014 Reconfigured: new=0 old=1 dropped=0 (services)

    This is running on a fresh installation of 2.3 beta latest from earlier today.
    Hardware is celeron n3150 based mini pc, not ideal but i had it to hand at the time

    Thanks





  • i'm not sure, powerd is definately working. as the freequency is changing, running powerd -v shows it's working. just cannot change the profiles between hiadaptive, adaptive, minimum and maximum it seems to be 'stuck' on hiadaptive.


  • Developer Netgate

    I don't believe those options are saving correctly. Checking now.



  • ye i've just tried changing /boot/device.hints to
    hint.acpi_throttle.0.disabled="0"
    hint.p4tcc.0.disabled="0"

    and no difference so i'll change them back to default



  • Sorry to mislead you :(


  • Developer Netgate

    Indeed the variable names did not match the configuration names. Just pushed a fix and can confirm the config file is being updated correctly and the web page shows the correct configuration.

    Please gitsync and re-test.



  • it still doesn't seem to be working right

    although it may be my mistake

    used option 13 - update from console using sshd
    then rebooted the system

    still a lot to learn



  • Go to console.
    Choose option 12 (developer shell)
    then type in:
    playback gitsync master  –> press enter.

    This is how you must do it.


  • Developer Netgate

    Once you have done that, you could also visit the "Diagnostics->Command prompt" page. In the shell command box, type:

    grep powerd /cf/conf/config.xml
    

    That should show you the current powerd settings.



  • @apollo17:

    it still doesn't seem to be working right

    although it may be my mistake

    used option 13 - update from console using sshd
    then rebooted the system

    It takes up to several hours before updates are available there. You have to gitsync to get them faster, as maverick_slo indicated. That's only if you want to immediately get a change that was made very recently, otherwise stick with option 13 at console for upgrading.



  • Ok, have gitsynced and everything seems to be working

    grep powerd /cf/conf/config.xml showed the settings changed as they should.

    thanks guys for your help


Log in to reply