Squid 4.3.10/squidGuard 1.9.18 not filtering



  • Hello,

    I am running squid 4.3.10/squidGuard 1.9.18 to filter content for my school district.
    Transparent Proxy is not checked.

    When proxy settings are set in Internet Explorer, the content filtering works wonderfully.
    When I uncheck the proxy settings in Internet Explorer, the Internet still works and nothing in filtered. It used to work correctly, but I must have changed something.

    Any ideas? I reinstalled and setup everything to try and fix it. Could something on my network be bypassing my pfSense?



  • Transparent Proxy is not checked.
    When proxy settings are set in Internet Explorer, the content filtering works wonderfully.
    When I uncheck the proxy settings in Internet Explorer, the Internet still works and nothing in filtered.

    Your answer is right there in front of you.  Transparent mode doesn't need any client settings.  If you're not running in Transparent mode then you either need to manually set the proxy address per client, or push it via GPO or WPAD.  Note that Transparent mode will not work with HTTPS sites without generating a browser security error unless you import the pfSense certificate into every client.  Since this is often impractical, it's better to run the proxy in explicit mode (not Transparent), block off ports 80/443 from LAN to prevent users from going around the proxy, and configure GPO/WPAD.



  • I thought that having the Transparent Proxy option unchecked put me in explicit mode?

    How do I block off ports 80/443 from the LAN? That is not something that I did myself in the past, was it defaulted?



  • I thought that having the Transparent Proxy option unchecked put me in explicit mode?

    That is correct.

    How do I block off ports 80/443 from the LAN?

    By adding a block rule above the Allow All rule.