PC Engines APU2b4 and pfSense 2.3 Beta



  • Hi,

    I just received my new APU2 board !
    Using default config with an SSD mSata disk and a Sierra MC7710 4G modem.

    I flash with the latest BIOS a few days ago.

    I got some troubles with the latest beta :

    • Thermal sensor is not recognized with default or AMD settings, what's wrong ?
    • I am using the Sierra MC7710 with PPP (not Direct IP aka DIP mode) and ppp is crashing always, what's wrong ?

    Also I would like to try to use the Direct IP mode where it's an ethernet interface (trough USB) who are always up and running, it's more easy to manage and you avoid the ppp bandwidth bottleneck limitation around 25mb/s. But i need a kernel module who is not installed by default usie, is it possible to add it by default on next build ?

    Thanks in advance.

    Regards

    Nicolas

    ![Capture d’écran 2016-01-29 à 09.33.29.png](/public/imported_attachments/1/Capture d’écran 2016-01-29 à 09.33.29.png)
    ![Capture d’écran 2016-01-29 à 09.33.29.png_thumb](/public/imported_attachments/1/Capture d’écran 2016-01-29 à 09.33.29.png_thumb)



  • @nscheffer:

    I flash with the latest BIOS a few days ago.

    I got some troubles with the latest beta :

    • Thermal sensor is not recognized with default or AMD settings, what's wrong ?

    I too am having problems with the thermal sensors, I've contacted PC Engines, they advise that they are working in Linux and attached a picture of it working. There exists a 1 line kernel patch for openbsd to get temperatures working.

    My current more annoying problem with 2.3 (and 2.2) is that a reboot on the device locks the system up with three lights after it runs through all the shutdown procedures. Not good for remote reboots and more than an annoyance as a local reboot. :)



  • Update after some test today :

    • Sierra MC7710 4G Modem is working with PPP, not with DIP where i need to load a kernel module usie
    • DynDNS, Firewall, Reporting are working too.

    Now i would like to enable 2 features :

    • optimise bandwidth with Squid in Transparent mode, not working !
    • limit user traffic (shopping, quota, etc…) idea ?

    It seems Squid in transparent mode is broken ?



  • Yes, many of us are having squid issues. There has been no official reply as to why. I've spent countless hours trying to troubleshoot it without luck.



  • why? because the package is not fully adjusted / tested with the future release.



  • I totally reflashed my box today. Problem persists. I figured a clean installed might help.



  • @yodawg:

    My current more annoying problem with 2.3 (and 2.2) is that a reboot on the device locks the system up with three lights after it runs through all the shutdown procedures. Not good for remote reboots and more than an annoyance as a local reboot. :)

    I also had this reboot problems on my first tests I did, but with the latest pfSense 2.3 updates (now based on FreeBSD 10.3-PRERELEASE) these problems are gone.



  • It seems difficult to achieve a full test of the APU2 new board using pfSense 2.3 Beta.

    I decide to do a fresh clean install on the SSD with pfSense 2.2.6 and it's working for most of the feature :

    • Squid with transparent mode is working
    • Captive Portal (without Squid is working)
    • MC7710 is working using ppp
    • Limiter for user download and upload works fine

    Still not yet working using pfSense 2.2.6 :

    • LED
    • Thermal Sensor
    • Still need to try how to have MC7710 working using DIP mode

    Nicolas