Ipv6 static mapping deletes settings



  • adding ipv6 static rout deletes settings out of dhcpv6 for lan and deactivates it



  • Out of dhcpv6 what, server, client?



  • page reloads with Enable DHCPv6 server on interface LAN unticked

    and range blanked out



  • No clue what you're referring to. This on services_dhcpv6.php? There are no static route fields there.



  • firewalladdress/services_dhcpv6.php?if=lan

    ![Screen Shot 2016-01-29 at 9.55.21 PM.png](/public/imported_attachments/1/Screen Shot 2016-01-29 at 9.55.21 PM.png)
    ![Screen Shot 2016-01-29 at 9.55.21 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2016-01-29 at 9.55.21 PM.png_thumb)



  • Oh, static mappings. Hm, can't replicate that even adding exactly what you show there. Is it only when you add a new entry there, or also if you edit one?



  • it happened  when adding new haven't tried editing but was repeatable go to firewalladdress/status_dhcpv6_leases.php  one of the plus's next to a mac you want to add as a static mapping (i was leaving ipv6 blank) add it all apears fine till you apply it then blanks out and disables with out any errors

    hopefully that is more clear frequently get introuble for to short of answers



  • was anything else needed to reproduce this issue?



  • I had raised this very issue last week.

    https://forum.pfsense.org/index.php?topic=106476.msg593734#msg593734

    No one responded. Maybe since the post topic was on DNS.



  • yes still a problem



  • I couldn't replicate anything noted here. Saw Asterix's post last week and thought maybe adding from the lease status page would be the ticket, but that didn't break for me either. Anyone know what it is that makes it replicable? What does the diff in the config history show when doing so, is it actually unsetting those conf settings or is it just the GUI not displaying what's in the config?



  • services_dhcpv6.php made unknown change Current configuration
    2/17/16 19:14:40 14.4 157 KiB grandrivers@2001:470:1f11:f4c:ffff:ffff:fffe:74f8: /services_dhcpv6_edit.php made unknown change



  • browsed away to dash board and back its definitely unset



  • What's the actual diff between the config revisions show?

    Just tried again adding a static mapping from the leases screen, and it works fine. services_dhcpv6_edit.php doesn't unset anything. Only way I see where it could blank out the config is if it didn't pass is_array check towards the top of that file, but not seeing any way that's possible where it's enabled.



  • if i pm you my config would it help ?



  • It might. I'd really just like the diff between the config revisions to see exactly what changed upon adding the new entry, that'd be most helpful.



  • – /conf/backup/config-1455747016.xml 2016-02-17 17:10:24.883655000 -0500
    +++ /conf/backup/config-1455743825.xml 2016-02-17 17:10:16.672696000 -0500
    @@ -2932,8 +2932,8 @@

    <revision>- <time>1455747016</time>

    • <time>1455743825</time>

    <username>grandrivers@2001:470:1f11:f4c:e722:ea61:fd24:e0bb</username></revision>
    <openvpn>@@ -3011,14 +3011,6 @@
    <rasamednsasdhcp6><radnsserver>2001:470:1f11:f4c::1</radnsserver>
    <enable>- <staticmap>- <duid>00:01:00:01:17:82:76:9f:c8:9c:dc:aa:c4:62</duid>

    • <ipaddrv6>2001:470:1f11:f4c:846c:9ed:1dbe:c3d8</ipaddrv6>
    • <hostname>Austin-pc6</hostname>
    • <descr>-<filename></filename>
      -<rootpath></rootpath>
      -</descr></staticmap>

    <opt2><ramode>disabled</ramode></opt2></enable></rasamednsasdhcp6></openvpn>



  • this is more current

    – /conf/backup/config-1455781101.xml 2016-02-18 21:08:58.099835000 -0500
    +++ /conf/config.xml 2016-02-18 21:09:00.846378000 -0500
    @@ -2933,9 +2933,9 @@

    <revision>- <time>1455781101</time>

    • <username>(system)</username>
    • <time>1455847740</time>
    • <username>grandrivers@2001:470:1f11:f4c:ffff:ffff:fffe:74f8</username></revision>
      <openvpn><dnshaper>@@ -2979,36 +2979,36 @@
      <dhcpdv6><lan><range>- <from>2001:470:1f11:f4c::2</from>
    • <to>2001:470:1f11:f4c:ffff:ffff:ffff:0000</to>

    +</range>
    <prefixrange>- <from>- <to>- <prefixlength>48</prefixlength>

    +<prefixlength></prefixlength></to></from></prefixrange>

    • <defaultleasetime>- <maxleasetime>- <netmask>+<defaultleasetime></defaultleasetime>
      +<maxleasetime></maxleasetime>
      +<netmask></netmask>
      <failover_peerip>- <domain>- <domainsearchlist>- <ddnsdomain>- <tftp>- <ldap>+<domain></domain>
      +<domainsearchlist></domainsearchlist>
      +<ddnsdomain></ddnsdomain>

    +<ldap></ldap>
    <nextserver><filename><rootpath>- <dhcpv6leaseinlocaltime>+<dhcpv6leaseinlocaltime></dhcpv6leaseinlocaltime>
    <numberoptions><ramode>managed</ramode>
    <rapriority>high</rapriority>
    <rainterface><radomainsearchlist>- <bootfile_url>- <ddnsdomainprimary>- <ddnsdomainkeyname>- <ddnsdomainkey>+
    +<ddnsdomainprimary></ddnsdomainprimary>
    +<ddnsdomainkeyname></ddnsdomainkeyname>
    +<ddnsdomainkey></ddnsdomainkey>
    <rasamednsasdhcp6><radnsserver>2001:470:1f11:f4c::1</radnsserver>
    <staticmap>@@ -3019,8 +3019,7 @@
    <filename><rootpath></rootpath></filename></staticmap>

    • <ddnsclientupdates>allow</ddnsclientupdates>
    • <enable>+<ddnsclientupdates></ddnsclientupdates></enable></rasamednsasdhcp6></ddnsdomainkey></ddnsdomainkeyname></ddnsdomainprimary></bootfile_url></radomainsearchlist></rainterface></numberoptions></dhcpv6leaseinlocaltime></rootpath></filename></nextserver></ldap></tftp></ddnsdomain></domainsearchlist></domain></failover_peerip></netmask></maxleasetime></defaultleasetime></lan>
      <opt2><ramode>disabled</ramode></opt2></dhcpdv6></dnshaper></openvpn>

  • Rebel Alliance Developer Netgate

    Does that loss happen on save, or on apply?

    We had a similar case happen somewhere else (dns forwarder maybe?) where the apply button was causing a loss due to how it was submitted.



  • on hitting apply


  • Rebel Alliance Developer Netgate

    OK, that really sounds like what was happening here: https://redmine.pfsense.org/issues/5488 – though that was the DNS Forwarder settings. A similar fix may be necessary on this page. May as well open a ticket on redmine for that, referencing the older ticket.



  • Was able to replicate this again last night. Was fiddling with CARP with 1 static IP and adding IPv6 to the mix. That didn't go well..but that's a discussion for another group.

    So, here's what I did..
    Enabled DHCPv6 RA. My laptop picked up the IPv6 address.. of course it wasn't the one I wanted to assign from the pool as I allocate static DHCP ips to all my network devices. So I went into the DHCPv6 leases and clicked on the + icon to assign using the DUID it was using. Punched in the desired IPv6 address and hit save. The page refreshed to DHCPv6 page showing the service disabled (box unchecked) with all my DHCPv6 settings gone.. but the static entry was added to the end of the page.


  • Rebel Alliance Developer Netgate

    I was able to reproduce this and checked in a fix. It works for me in each of the problem scenarios here. Give it a shot once you get a snapshot that includes it (or gitsync in a few minutes to get it)



  • Awesome! .. Thank u!