HE Tunnel GIF Interface MTU at 1280



  • Just installed the latest snapshot. Clean install from scratch. It looks awesome.

    I noticed the HE Tunnel GIF interface defaults to 1280 MTU. I entered 1500 manually in the interface settings and it reflects the updated setting in the interfaces status. But when I reboot it goes back to 1280 even when the manually entered 1500 setting is on the interface. I have to re-apply to make it stick to 1500 for the time the machine hasn't rebooted.



  • anyone?



  • If it helps, tunnelbroker.net advanced setting for tunnels allows a maximum MTU setting of 1480 only.



  • Yup.. I saw that. It's on (Default) 1480. Do notice the (Minimum) 1280 is an option as well. I should at least see 1480 on the tunnel interface in pfSense but its picking up the minimum 1280 which is not even set at tunnelbroker.net.

    Seems a bug to me.



  • You can't set it to 1500 (it configures fine that way, but that won't work over the Internet), but 1480 looks to work fine. It's set that way upon applying on interfaces.php, and set after reboot.



  • 1480 works. Thanks

    So everytime I install from scratch and configure HE interface I need to set it to 1480? Can't this be automated?



  • 1280 is the FreeBSD default for gif interfaces (and actually what he.net's FreeBSD instructions will give you), we use the FreeBSD default where MTU isn't user-defined.



  • @Asterix:

    1480 works. Thanks

    So everytime I install from scratch and configure HE interface I need to set it to 1480? Can't this be automated?

    On HE in your tunnel settings you have the Advanced tab. There you can change MTU, the default one is 1480. You should be OK if you have not change it.



  • @mais_um:

    @Asterix:

    1480 works. Thanks

    So everytime I install from scratch and configure HE interface I need to set it to 1480? Can't this be automated?

    On HE in your tunnel settings you have the Advanced tab. There you can change MTU, the default one is 1480. You should be OK if you have not change it.

    Check my third post.



  • I had read it before but I forgot, this topic is always important to me. Then i don't understand the Automated word, should be 1480 by default on a GIF interface?. I don't know the default on other IPv6 tunnels. I use HE so to me yes.



  • HE here as well. Yup default 1480 should be good. It's 1280 right now.



  • So will the code be updated to default the tunnel MTU to 1480?



  • The default of 1280 is because that is the minimum MTU required by the IPv6 RFCs.

    A default tunnel MTU of 1480 would be problematic, because that incorrectly assumes the parent interface supports an MTU of at least 1500, allowing for the 20 byte overhead of tunnelling. PPPoE has a maximum MTU of 1492 (unless RFC 4638 is in use). I have a cellular modem that has a maximum MTU of 1460. There will be many other examples of parent interfaces that cannot support MTU 1500 operation.



  • But the problem I am facing is that manual MTU setting for HE interface is not sticking after a reboot. I set it to 1480 and after a reboot it goes back to 1280. And yes tunnel broker has 1480 set in the advanced tab.



  • What is the MTU of the parent connection(WAN)? Either way you should be able to put 1480. Tray 1452, this is ideal for some pppoe connections. 1452 is the MTU i have in he.



  • I am on cable.. 1500.

    I am able to make it stick to even 1500 but once it reboots it goes back to default 1280.





  • The tunnel has an overhead of 20 bytes for the IPv4 header meaning the maximum MTU of the tunnel can be is 1480 for a connection with an MTU of 1500.



  • @Asterix:

    I am able to make it stick to even 1500 but once it reboots it goes back to default 1280.

    My setup had a static IP WAN, I can replicate that with DHCP WAN.

    Fixed.
    https://redmine.pfsense.org/issues/5842



  • Nice. Caught 2 bugs this week which were rectified.

    I should be knighted… lol  ;)

    All hail Sir Asterix !!!    ;D ;D