WiFi AP throughput performance with SG-2440

  • Hello,

    Just had my first experience with pfsense and have been very impressed so far. However, my wifi throughput seems a bit on the slow side and I was hoping someone in these forums could provide some insight.

    Here's my setup:

    SG-2440 (recently purchased) with WAN connected to comcast cable modem with the 100Mbit plan
    LAN and OPT1 are bridged together.
    LAN connects to a gigabit switch and the rest of my hard-wired home setup
    UniFi UAP-AC-PRO AP connected to OPT1
    ubuntu 14.04 LTS laptop with gbe and 802.11n wifi

    Here's the numbers that do make sense

    • gigabit ethernet cable between my 2yr old laptop and the SG-2440
    • iperf reports gigabit speed between laptop and pfsense
    • from laptop, speedtest.net reports 125Mbps down.
    • note that a gigabit ethernet cable from my laptop to the switch and then to the router also reports 125Mbps throughput down (via speedtest.net).

    Here's the numbers that don't make sense:

    • 802.11n connection from laptop to UAP-AC-PRO AP
    • iperf between laptop and pfsense reports 15.5 Mbps
    • iperf between laptop and server connected to the switch reports ~20 Mbps.
    • from laptop, speedtest.net reports 42 Mbps down.

    My previous setup was one of those consumer-grade routers with dd-wrt and I was able to get 52Mbps down over the wifi (speedtest.net).  The original reason I started to investigate and eventually settled on pfsense was that dd-wrt throughput maxes out around 100Mbps (even for gbe) and I thought I could do better…

    I'm really just looking for some pointers or suggestions of places to look to improve the performance - or even knowledge that this is the best I can expect.  I'm not a networking guru, but my first linux install was 1995 and I have managed small HPC clusters, so I'd like to think not completely clueless.  :P


  • Hi i have simular setup.

    Fiber modem –> SG4860 --> Cisco SG200-8P Switch
    ----------------------------------> UAP-AC-Pro

    With this i can achive 100 Mbit / 100 Mbit over wireless. My full dl/ul speed.

    I would suggest you try connect the Unifi to your switch.
    Also make sure that in Uniifi Controller --> Settings --> Site: "Enable connectivity monitor and wireless uplink" is disabled.
    And you are on the latest Controller and AP point firmware, they made some speed improvements.

    I don't know exactly what speed you could expect using an 802.11n device. I tested using an iPhone 6 using AC and i got great numbers.

  • Thanks for your reply! I tried connecting the Unifi directly to my switch, but I didn't seem to be able to get the wifi numbers to budge much above the 50Mbps level.  Seems like that's just about as fast as one can get 802.11n to go.  With a new 802.11ac device, I can get close to the 100Mbps over the wifi.

  • Is your laptop 802.11n 2x2 (300Mbps) or 1x1 (150 Mbps).

    I had a Comcast Blast plan with 125Mbps download and with dd-wrt running on a Linksys E3000, I was able to get over 100Mbps on speedtest.net with my 802.11n 2x2 laptop.

    I now have symmetrical gigabit Internet and is using the UAP-AC-Pro connected to my c2758 pfSense and with the same laptop I can get 170Mbps down/ 208Mbps up on speedtest.net.  With iperf3, I can get symmetrical 210Mbps.

    With a NETGEAR R7000 running dd-wrt in AP mode instead of the UAP-AC-Pro, I get similar results.  On dd-wrt with a 802.11ac 2x2 device, I get over 300Mbps with iperf3.  So I have never experience dd-wrt maxing out at  100Mbps.

  • It's a Lenovo T430 which has an Intel Centrino Advanced-N 6205 (2x2) on which I've installed Ubuntu 14.04.

    I'm beginning to think I've somehow not configured my laptop wifi correctly…though I just used the standard configuration setup in Ubuntu.

    Also, I tried turning off the "Enable connectivity monitor and wireless uplink", but it didn't seem to change anything in terms of speed.

  • My laptop is a Lenovo Thinkpad X3 with the exact same WiFi card.  I am running Windows 10 though.  Could be a driver issue.

  • I've looked at that and it's just odd.  When I look at the device/wifi "information", the speed bounces around from 144 to 175 to 195 Mbps.  However, speedtest.net says I can download at 46 Mbps.  When I use iperf over the wifi to the SG-2440, it reports about 20Mbps.

    I really feel like I'm just missing something obvious…  It's just hard for me to believe that the system / the driver can report such a high Mbps and I will only get such a low effective Mgps.  And, if I do this over the wired ethernet, I get exactly what I expect for speed of download.

  • What you are seeing in the device/wifi "information" is probably the physical layer link rate and not the application layer throughput, which will be lower.  Speedtest.net is reporting the application layer throughput.

    It is odd that your iperf is less than speedtest.net.  Try running 8 streams and a TCP window size of 1024k.  See if that saturates your link.  If your SG-2440 is running iperf in server mode, then you need to issue the -R to have the server send data to you laptop.  iperf3 and iperf2 command parameters are slightly different so check the iperf doc for whatever version of iperf that you are using.

  • LAYER 8 Global Moderator

    how does this have anything to do with pfsense?  If your having speed problems with your unifi I would go to their forums..  But your missing some very important info here.. What speed are you connecting at?  Look in your wifi controller it will show you what speeds both tx and rx that client its connected at if you don't know how to read it at the client side.

    Keep in mind this is PHY, do a /2 of that number to get close to what you might see in real world speeds.

    You say 2x2 n, but is that 20mhz or 40mhz channels?  Is that 2.4 or 5ghz?  What is the signal strength, what other wifi do you have in the area..

    But your connecting from your wifi to a device on your switch, your not routing this through pfsense are you?  So this really has nothing to do with pfsense at all.

  • I completely agree that this might have nothing to do with pfsense.

    Originally, I swapped out a DD-WRT router for a pfsense router and noticed a change in throughput over wifi from speedtest.net - it appeared to be consistently 20% lower.  When I ran iperf (between pfsense and my laptop), I was getting very low Mbps numbers (note that I never ran iperf on the DD-WRT, however).  So, I deduced that I did not understand (or had misconfigured) pfsense in some way.  This was why in my original post, I just tried to provide as much info as I could in the hopes that there was something obviously off that I had done (since I am relatively new to pfsense).

  • LAYER 8 Global Moderator

    As to difference in speed to your isp.. Sometimes when you change devices connected to an ISP they might put you on a different tier for awhile.  Its possible that the network your connected to via this new IP might be slower than the network you were on.  Was the IP you got via pfsense in the same network as before?

    How exactly did you run iperf?  As mentioned there are some differences in how you run it, what was the window size, were you doing tcp or udp.  How many streams?  My pfsense is on vm on older hp n40l host via esxi.  I can not route at full gig speeds..  My internet plan is only 75/10 is what I pay for.. But I can peg that without any problems I see speed tests on speedtest.net all the time of 80+ and 12 up..

    I see these speeds on my wifi devices without any issues when the wifi device connects at a wifi speed that can do that.  So for example my ipad air2 that does AC 2x2 I see my max internet connection.  But when say on my iphone 5s that does not support AC I only see normally in the 60mbps range.  All comes down to what your connecting at PHY, your signal strength, any other wifi connected at same time, what those devices are doing.  Noise in the area, etc.

    To get 125Mbps wifi you would need to be at min I would think.. 2x2 40mhz channels short guard.. This gives you a possible PHY of 300 do your /2 of that and ok you might get 125mbps..  But that would have all the other factors that come into play with wifi.

    If your connecting at 2x2 20mhz with normal 800 ns guard your looking at a top PHY of 130.. /2 that and your no where close to your 125mbps internet speed.

    I would look to what your client reports its PHY connection rate are at..  And then do the /2 to put you in the ballpark of what would be realistic to see if all other aspects are good.  Clearly your pfsense is good since your doing your 125mbps with a wire.  So pfsense doesn't care or give a shit or even know that the traffic was wifi before it got to pfsense..  So if your not seeing the speeds that the wire gets you need to look at your wifi to why that is.

  • Thanks - I'll pursue the wifi angle then.

  • LAYER 8 Global Moderator

    Do you have the older AC pro model from unifi or the new gen2 stuff?  I have the lite, the pro and the lr of their new ac line and be happy to do some testing for you.  I could fire up something that is on the same network via wire as the wifi and do some testing of speed with iperf..  I do have a pci card I could use that is 3x3 on pc, but never use it for anything other than testing since pc got a gig wired connection so no real use of wifi even if 3x3 AC.. Never going to come close to gig wire.. Even at 3x3 80mhz channels short gi your talking 1300 PHY which is only 650ish real world.. I see low 900's with a wire ;)

    3x3 clients really rare and 80 mhz not very common either so typically your talking 2x2 at 40 even on AC.. But could do some benchmarks with those PHYs or some lower ones..  Could change over to 40mhz for example.