VLAN inter comm / routing issue, cannot access other vlan from vlan



  • Hey guys, so I'm testing out pfsense with my new supermicro server with 8 core atom, anyways, I'm coming from zeroshell and want to migrate to pfsense to utilize the multi openvpn client streams.

    So trying to copy over the zeroshell config, which I have 4 vlans, which some can communicate with each other.  These vlan are on a LAGG, lacp.  That's working fine because I can obviously access wan/pfsense from those vlans through my C2960X.

    For pfsense, for the life of me, I cannot have one host in vlan 10, communicate to vlan 20.

    I don't know what's wrong, my rules are just a simple allow * * * * any etc.

    I can access WAN from any vlan, and any vlan can access the webUI config page but never other vlans host.

    I tried to from a fresh install and all I setup is vlan's, wan, dhcp for all vlans, that's about it.

    So is there an issue with some rules or is it vlans + lag have issue with inter routing?



  • Alright, fixed it, was due to my "lan" interface having same subnet as one of vlans for my initial setup and testing…