[solved] squidguard safesearch / rewrite dosent work



  • Hi,
    I'm trying pfsense for several days now and find it impossible to have safe-search enforced
    I'm using squidguard

    Tried using the blacklist "safesearch" of http://www.shallalist.de/Downloads/shallalist.tar.gz

    rew safesearch {
    s@(google../search?.q=.)@&safe=active@i
    s@(google..
    /images.q=.)@&safe=active@i
    s@(google../groups.q=.)@&safe=active@i
    s@(google..
    /news.q=.)@&safe=active@i
    s@(yandex../yandsearch?.text=.)@&fyandex=1@i
    s@(search.yahoo..
    /search.p=.)@&vm=r&v=1@i
    s@(search.live../.q=.)@&adlt=strict@i
    s@(search.msn..
    /.q=.)@&adlt=strict@i
    s@(.bing..*/.q=.)@&adlt=strict@i
    log block.log
    }

    And tried configuring rewrite rules by my self according to what i found in various forums

    rew My-List {
    s@(.*youtube.com/.v=.)@&&safety_mode=true@i
    s@(.google../.q=.)@&&safe=strict%26@i
    s@(.duckduckgo.com.)@&&kp=1@i
    s@(.*bing.com/.q=.)@&&adlt=strict%26@i
    }

    only duckduckgo was enforced, the rest didnot

    any suggestions ?



  • As far as the Google Safe Search, you will need to create a DNS entry in your DNS Forwarder to force a safesearch.

    But youtube, bing, yahoo, and several others have changed how they do content filter, and use a local cookie (not sure how it would be possible to enforce a safe search, ever now)… The other problem is, with most websites being HTTPS, unless you are using a MITM attack to force HTTPS through SQUID, the SquidGuard settings will never apply.

    TBH, I would set Bing, Yahoo, and pretty much all other search engines, to use the forced google safe search... Might upset your users, but, not much you can do anymore.
    https://support.google.com/websearch/answer/186669?hl=en



  • thanks for the suggestion, i actually used the DNS option and its working both for Google and Youtube

    the rewriter method seem to work partially in a weird way - i see it in firefox only - when i search something, then browse to another page and then coming back to the search page (using back button) i see that the URL is containing the rewrite strings and if i refresh the page it switch to safesearch mode…



  • How did you get youtube to work properly with the safesearch?  That is something I have been wanting to do, but, haven't had luck with as far as I can tell… How does one even test that it works?  (Still learning a good bit along with everyone else)



  • I had to set the "URI Whitespace Characters Handling" in Squid Settings to "chop" in order to get the Safesearch rewrite feature to function properly.

    Chad



  • @cwagz:

    I had to set the "URI Whitespace Characters Handling" in Squid Settings to "chop" in order to get the Safesearch rewrite feature to function properly.

    Chad

    Changing URI setting seem to solve it - Thanks a lot ! :)

    This is the list I have the works for me

    rew My-List {
    s@(.youtube.com.)@&&safety_mode=true@i
    s@(.google../.q=.)@&&safe=active@i
    s@(.duckduckgo.com.)@&&kp=1@i
    s@(.bing.com.)@&&adlt=strict@i
    s@(.search.yahoo.com.)@&&vm=r@i
    s@(.yandex.com/.)@&&fyandex=1@i
    }

    As for Youtube safesearch, i have similar DNS ocnfiguration (see attachments)








  • @C0RR0SIVE:

    How did you get youtube to work properly with the safesearch?  That is something I have been wanting to do, but, haven't had luck with as far as I can tell… How does one even test that it works?  (Still learning a good bit along with everyone else)

    see my last post on how to setup dns safesearch for youtube
    and as for how to check it … i tried searching "sex" and compared the results. its not perfect, but will settle  for what they offer



  • This post is deleted!

Log in to reply