Problema con le pagine di captive portal



  • Ho installato pfsense, configurato con regole OK, 3 schede di rete WAN LAN e Guest, tutto funziona tranne il captive portal…
    mi spiego.... attivo il captive portal sulla scheda Guest, come è giusto che sia nessuno naviga più da quel ramo di rete, tranne i MAC che inserisco come passtrouth, ma ai client non compare MAI la pagina di autenticazione, mentre continuo a pingare l'indirizzo della scheda Guest.
    Ho installato da ZERO tre volte il software, utilizzando a turno le tre schede di rete presenti come Guest... ma niente!!

    Grazie in anticipo chi mi da una dritta.



  • Ciao,
    il redirect funziona solo se:

    • la prima pagina che richiedi non è in https
    • la porta 8002 sull'IP del firewall è raggiungibile

    Se accedi all'ip del firewall nella lan guest sulla porta 8002 ti si deve aprire la schermata del captiveportal es http://10.0.0.1:8002

    Ciao Fabio



  • Scusa il ritardo Fabio, ma ho avuto dei problemi….

    la risposta è si, se inserisco l'indirizzo, nel mio caso 10.10.10.10:8002 appare la finestra di login con la richiesta di credenziali.
    mentre se inserisco un indirizzo http://xxxx.yyy non apre nessun pop-up di richiesta credenziali di accesso.

    Ciao e grazie



  • Farei una prova visto che mi pare di ricordare un problema similare da un cliente…

    Inserisci nei siti che bypassano il captive portal l'indirizzo che hai dichiarato come DNS dei client (esempio 8.8.8.8).

    Infatti se non si apre il DNS il CP si mette in mezzo e non permette la risoluzione corretta dei nomi dns.



  • Esatto, è necessario che il DHCP assegni come DNS l'IP del pfsense.


Log in to reply