Pfblockerng



  • good day!

    im on pfsense 2.2.4 with pfblockerng 2.0.4.
    after installation of pfblockerng, it was working fine. but after a day. no more packets were blocked. (set to deny both)

    how can i test if pfblockerng is really working?

    ty
    jb



  • Well I would go to the logs and look at the pfblockerng.log and error.log to see what is wrong.

    To test if pfblockerNG blocks, try to access some of the IPs contained in any Deny Files block lists.



  • Firewall and/or IDS are not blocking download - in the error.log

    there seems to be no error in the pfblockerng.log..

    i can access the ip's block list..

    im at a loss. installed in 2 separate servers..same error..will work for a few minutes/hours then the next day it will stop
    blocking..

    thanks for the reply

    jb


  • Moderator

    Hi bertobass,

    The widget screenshot looks ok. It shows that it created rules for each alias. Check the pfBlockerNG 'General Settings' tab, and ensure you selected the correct Inbound/Outbound Interfaces. If its still an issue, post a screenshot of the WAN/LAN rules.

    There are also errors in downloading some of the lists, as you can see "123 errors"… Check the pfblockerng.log for clues... Some of the URLs have been discontinued (Juniper) and some lists need the 'flex' state to be set.

    Note:

    Here is a post which indicates most of the URL issues:
    https://forum.pfsense.org/index.php?topic=86212.msg587955#msg587955



  • attached is the LAN / WAN rules / interfaces

    i tried to access ip's in the block list..it can go through

    thank you







  • Moderator

    Nothing strange there. Would you mind posting a screenshot of the pfBlockerNG dashboard widget.

    Edit: I forgot that you posted the widget before. I don't see any issues with what your posting. Have you tried a reboot or a filter reload?  You are also on pfSense  v2.04, maybe update to 2.2.6?