[Solved] Can't start OpenVPN from GUI



  • Hey guys,

    I'm trying to setup openvpn but i never manage to get it started.

    It always fails when starting from webGUI

    
    openvpn[18862]: Assertion failed at crypto.c:168
    openvpn[18862]: Exiting due to fatal error
    

    If I run it from shell it works and I can establish a tunnel.

    Any ideas?

    Edit: It works now :D. I made a mistake pasting the ta.key into the gui. After countless hours trying to find the error I pasted all the certs and keys again and now it works.



  • Other individuals with this issue have reported that switching the cipher to something else, i.e. AES-128-CBC 128 bit may correct the problem.



  • I'm using AES-128-CBC. It works when using the shell to start the tunnel.



  • As a troubleshooting step, have you tried to change the cipher and bring up the tunnel in the GUI?



  • It only works with "cipher none" in the gui. I've made a cron job now to check on the status and restart it if needed. Just gotta live without the GUI ;)



  • What do you have chosen for "Hardware Crypto" in your OpenVPN config? Is this on your SG-2220? I presume with the default crypto options under System>Advanced, having AES-NI enabled.

    Past instances of this were all in pre-release 2.2.0 versions with certain ciphers and certain hardware crypto. Those were attributable to a problem in OpenVPN that we got fixed in OpenVPN pre-2.2.0 release. But apparently there is still some combination of options there that triggers the same issue.


Log in to reply