Dyndns error in latest snap



  • im on the alix nanobsd and the latest snap has issues updating ip of dyndns

    Feb 10 11:52:26 	php-fpm 	11117 	/services_dyndns_edit.php: phpDynDNS: (ERROR!) No Password Provided.
    Feb 10 11:52:26 	php-fpm 	11117 	/services_dyndns_edit.php: phpDynDNS: (ERROR!) No Hostname Provided.
    Feb 10 11:52:26 	php-fpm 	11117 	/services_dyndns_edit.php: DynDNS (firewall.) There was an error trying to determine the public IP for interface - (). Probably interface is not a WAN interface. 
    

    i went to dyndns page, hit edit and it shows all the fields populated properly but hitting save doesnt resolve it



  • I have the same error, this is in syslog on reboot after the updating:

    
    2/10/16 11:50:55.000 php-fpm[53254]: /rc.dyndns.update: phpDynDNS: (ERROR!) No Password Provided.
    2/10/16 11:50:55.000 php-fpm[53254]: /rc.dyndns.update: DynDNS (dv.9summer.com) There was an error trying to determine the public IP for interface - (). Probably interface is not a WAN interface.
    
    

    And later on (OPT1 is not a WAN interface and is not selected in my dyndns settings):

    
    2/10/16 13:49:04.000 check_reload_status[-1]: updating dyndns opt1
    
    

    I just tried to edit and save the dynamic dns settings:

    
    2/10/16 14:06:41.000 pfs.dv.loc nginx[-1]: 2601:18a:c201:d5c0:3e07:54ff:fe5a:6093 - - [10/Feb/2016:14:06:41 -0500] "GET /services_dyndns_edit.php?id=1 HTTP/1.1" 200 5994 "https://pfs.dv.loc/services_dyndns.php" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0"
    2/10/16 14:07:07.000 check_reload_status[-1]: Syncing firewall
    2/10/16 14:07:07.000 php-fpm[62517]: /services_dyndns_edit.php: DynDNS (dv.9summer.com) There was an error trying to determine the public IP for interface - (). Probably interface is not a WAN interface.
    2/10/16 14:07:07.000 pfs.dv.loc nginx[-1]: 2601:18a:c201:d5c0:3e07:54ff:fe5a:6093 - - [10/Feb/2016:14:07:07 -0500] "POST /services_dyndns_edit.php?id=1 HTTP/1.1" 302 5 "https://pfs.dv.loc/services_dyndns_edit.php?id=1" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0"
    2/10/16 14:07:08.000 pfs.dv.loc nginx[-1]: 2601:18a:c201:d5c0:3e07:54ff:fe5a:6093 - - [10/Feb/2016:14:07:08 -0500] "GET /services_dyndns.php HTTP/1.1" 200 3781 "https://pfs.dv.loc/services_dyndns_edit.php?id=1" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0"
    
    


  • Thanks, should be fixed if you gitsync in ~15 minutes from the time of this post.



  • i applied the patch manually but still broken



  • u patched to add the below

    $dnsDomain = $conf['domain'],
    

    whereas it should be

    $dnsDomain = $conf['domainname'],
    


  • Really fixed this time, thanks xbipin.


Log in to reply